summaryrefslogtreecommitdiff
path: root/net-vpn/gp-saml-gui
diff options
context:
space:
mode:
Diffstat (limited to 'net-vpn/gp-saml-gui')
-rw-r--r--net-vpn/gp-saml-gui/Manifest2
-rw-r--r--net-vpn/gp-saml-gui/gp-saml-gui-9999.ebuild23
-rw-r--r--net-vpn/gp-saml-gui/metadata.xml20
3 files changed, 45 insertions, 0 deletions
diff --git a/net-vpn/gp-saml-gui/Manifest b/net-vpn/gp-saml-gui/Manifest
new file mode 100644
index 0000000..ecb2d03
--- /dev/null
+++ b/net-vpn/gp-saml-gui/Manifest
@@ -0,0 +1,2 @@
+EBUILD gp-saml-gui-9999.ebuild 557 BLAKE2B 155be64cb394398137702af8bd3acfcc00b5d3aa27f053ca97890883084fcaa06f887261ec9f892eab5071202808844c31a5c7c1830c46cc90b03d6df65204b6 SHA512 ea8dc7960e70c3c89233c85d0d7696228939c6034cc17f8af26efbe813e5668738a69e475b4e0c00f862cf77a0ca478093eeb0a62b6eb0a66527aa3ce096088c
+MISC metadata.xml 696 BLAKE2B fd226c1d12bab2ba8bb08eab8a8dba5ab802faf31be26912f364c25f855ba65946cd4254f5a92ea32772f70342c473022fa2c304a16ef87a71b0cf3a9f599666 SHA512 f6c18cead93256a904bf10602b139b5bc284f449b91a01ddf754f18a1a65acb40772e5b441850dd36fe624edae04db85399cfb8d5a5100e9cb268bec5d7ad79f
diff --git a/net-vpn/gp-saml-gui/gp-saml-gui-9999.ebuild b/net-vpn/gp-saml-gui/gp-saml-gui-9999.ebuild
new file mode 100644
index 0000000..a79c75f
--- /dev/null
+++ b/net-vpn/gp-saml-gui/gp-saml-gui-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Interactively authenticate to GlobalProtect VPNs that require SAML"
+HOMEPAGE="https://github.com/dlenski/gp-saml-gui"
+
+EGIT_REPO_URI="https://github.com/dlenski/gp-saml-gui.git"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ net-libs/webkit-gtk:4
+ net-vpn/openconnect
+"
diff --git a/net-vpn/gp-saml-gui/metadata.xml b/net-vpn/gp-saml-gui/metadata.xml
new file mode 100644
index 0000000..93f45ef
--- /dev/null
+++ b/net-vpn/gp-saml-gui/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <longdescription>
+ This is a helper script to allow you to interactively login
+ to a GlobalProtect VPN that uses SAML authentication, so
+ that you can subsequently connect with OpenConnect.
+ </longdescription>
+ <upstream>
+ <maintainer status="active">
+ <name>Dan Lenski</name>
+ </maintainer>
+ <bugs-to>https://github.com/dlenski/gp-saml-gui/issues</bugs-to>
+ <remote-id type="github">dlenski/gp-saml-gui</remote-id>
+ </upstream>
+</pkgmetadata>