summaryrefslogtreecommitdiff
path: root/net-vpn
diff options
context:
space:
mode:
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/globalprotect-openconnect/Manifest3
-rw-r--r--net-vpn/globalprotect-openconnect/globalprotect-openconnect-1.4.9.ebuild56
-rw-r--r--net-vpn/globalprotect-openconnect/metadata.xml19
-rw-r--r--net-vpn/gp-saml-gui/Manifest2
-rw-r--r--net-vpn/gp-saml-gui/gp-saml-gui-9999.ebuild23
-rw-r--r--net-vpn/gp-saml-gui/metadata.xml20
-rw-r--r--net-vpn/vpn-slice/Manifest3
-rw-r--r--net-vpn/vpn-slice/metadata.xml13
-rw-r--r--net-vpn/vpn-slice/vpn-slice-0.16.1.ebuild22
9 files changed, 161 insertions, 0 deletions
diff --git a/net-vpn/globalprotect-openconnect/Manifest b/net-vpn/globalprotect-openconnect/Manifest
new file mode 100644
index 0000000..f51f099
--- /dev/null
+++ b/net-vpn/globalprotect-openconnect/Manifest
@@ -0,0 +1,3 @@
+DIST globalprotect-openconnect-1.4.9.tar.gz 129646 BLAKE2B c264671b1e9d629382e339f3249a9effdaf05daadae762ece0207ef3bca9bc457b57b5925763be05b10f3727277a98af5d442c3ebb3b1ec06f5f9110c4fbb90e SHA512 6d6c2ad419e7c9d0f07c8d580c23102fa04b427fa0f03bca2158398deb0e3ff636a5a7b2fef20dc9b4de3e5b6571d6a1c137992a6809da65bd599b8167aff0cf
+EBUILD globalprotect-openconnect-1.4.9.ebuild 1374 BLAKE2B c36638fe35e36478291d4fafb521e626c7520f127070a6c09d5a923c574f0c39c685f44df2272dec0aefb7594b9039a8a5157bac2ecdb4c9e0df73f9b84f51d2 SHA512 27ee6b883da52e34169f731fa5ab372a0ac394f893c6fecfe81f7519119759ddc195d85a34cacae3c2e430fc56218ce36c00bedb1f49b37d50ad3203866844f8
+MISC metadata.xml 682 BLAKE2B 6fb38797ade477e52e7c0a623c1c72b4346dcb0789741b473162bc3b0dea6ca3562e3e702c4bb3733c6e1f0d8602e7042e95274939ed1c6bac3ded427fc04f21 SHA512 fe0154989cc25073ee764e8829c705e68ea6493197b8e92f2afd080bfe94aa0b87bbf4edfcc0949e48f8792bee9df1cfb4ec8fae2996ae52e71f2a0bf1857688
diff --git a/net-vpn/globalprotect-openconnect/globalprotect-openconnect-1.4.9.ebuild b/net-vpn/globalprotect-openconnect/globalprotect-openconnect-1.4.9.ebuild
new file mode 100644
index 0000000..b678136
--- /dev/null
+++ b/net-vpn/globalprotect-openconnect/globalprotect-openconnect-1.4.9.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="GlobalProtect VPN GUI based on Openconnect with SAML auth mode support"
+HOMEPAGE="https://github.com/yuezk/GlobalProtect-openconnect"
+SRC_URI="https://github.com/yuezk/GlobalProtect-openconnect/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/GlobalProtect-openconnect-${PV}"
+
+inherit cmake git-r3
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/qtkeychain[qt5]
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwebengine:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+ net-vpn/openconnect
+"
+RDEPEND="${DEPEND}"
+
+PLOG_REPO='https://github.com/SergiusTheBest/plog.git'
+PLOG_VERSION='1.1.9'
+SINGLEAPP_REPO='https://github.com/itay-grudev/SingleApplication.git'
+SINGLEAPP_VERSION='3.3.4'
+
+src_unpack() {
+ default_src_unpack
+ ## 3rd party submodules
+ # Plog
+ EGIT_REPO_URI="${PLOG_REPO}"
+ EGIT_COMMIT="${PLOG_VERSION}"
+ EGIT_CHECKOUT_DIR="${S}/3rdparty/plog"
+ git-r3_src_unpack
+ # SingleApplication
+ EGIT_REPO_URI="${SINGLEAPP_REPO}"
+ EGIT_COMMIT="v${SINGLEAPP_VERSION}"
+ EGIT_CHECKOUT_DIR="${S}/3rdparty/SingleApplication"
+ git-r3_src_unpack
+}
+
+src_compile() {
+ cmake -B build -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr" -DCMAKE_BUILD_TYPE=Release
+ cmake --build build
+}
+
+src_install() {
+ emake DESTDIR="${D}" install -C build
+}
diff --git a/net-vpn/globalprotect-openconnect/metadata.xml b/net-vpn/globalprotect-openconnect/metadata.xml
new file mode 100644
index 0000000..6416b7e
--- /dev/null
+++ b/net-vpn/globalprotect-openconnect/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <longdescription>
+ A GlobalProtect VPN client (GUI) for Linux based on Openconnect
+ and built with Qt5, supports SAML auth mode, inspired by gp-saml-gui.
+ </longdescription>
+ <upstream>
+ <maintainer status="active">
+ <name>Kevin Yue</name>
+ </maintainer>
+ <bugs-to>https://github.com/yuezk/GlobalProtect-openconnect/issues</bugs-to>
+ <remote-id type="github">yuezk/GlobalProtect-openconnect</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-vpn/gp-saml-gui/Manifest b/net-vpn/gp-saml-gui/Manifest
new file mode 100644
index 0000000..ecb2d03
--- /dev/null
+++ b/net-vpn/gp-saml-gui/Manifest
@@ -0,0 +1,2 @@
+EBUILD gp-saml-gui-9999.ebuild 557 BLAKE2B 155be64cb394398137702af8bd3acfcc00b5d3aa27f053ca97890883084fcaa06f887261ec9f892eab5071202808844c31a5c7c1830c46cc90b03d6df65204b6 SHA512 ea8dc7960e70c3c89233c85d0d7696228939c6034cc17f8af26efbe813e5668738a69e475b4e0c00f862cf77a0ca478093eeb0a62b6eb0a66527aa3ce096088c
+MISC metadata.xml 696 BLAKE2B fd226c1d12bab2ba8bb08eab8a8dba5ab802faf31be26912f364c25f855ba65946cd4254f5a92ea32772f70342c473022fa2c304a16ef87a71b0cf3a9f599666 SHA512 f6c18cead93256a904bf10602b139b5bc284f449b91a01ddf754f18a1a65acb40772e5b441850dd36fe624edae04db85399cfb8d5a5100e9cb268bec5d7ad79f
diff --git a/net-vpn/gp-saml-gui/gp-saml-gui-9999.ebuild b/net-vpn/gp-saml-gui/gp-saml-gui-9999.ebuild
new file mode 100644
index 0000000..a79c75f
--- /dev/null
+++ b/net-vpn/gp-saml-gui/gp-saml-gui-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Interactively authenticate to GlobalProtect VPNs that require SAML"
+HOMEPAGE="https://github.com/dlenski/gp-saml-gui"
+
+EGIT_REPO_URI="https://github.com/dlenski/gp-saml-gui.git"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ net-libs/webkit-gtk:4
+ net-vpn/openconnect
+"
diff --git a/net-vpn/gp-saml-gui/metadata.xml b/net-vpn/gp-saml-gui/metadata.xml
new file mode 100644
index 0000000..93f45ef
--- /dev/null
+++ b/net-vpn/gp-saml-gui/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <longdescription>
+ This is a helper script to allow you to interactively login
+ to a GlobalProtect VPN that uses SAML authentication, so
+ that you can subsequently connect with OpenConnect.
+ </longdescription>
+ <upstream>
+ <maintainer status="active">
+ <name>Dan Lenski</name>
+ </maintainer>
+ <bugs-to>https://github.com/dlenski/gp-saml-gui/issues</bugs-to>
+ <remote-id type="github">dlenski/gp-saml-gui</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-vpn/vpn-slice/Manifest b/net-vpn/vpn-slice/Manifest
new file mode 100644
index 0000000..584834f
--- /dev/null
+++ b/net-vpn/vpn-slice/Manifest
@@ -0,0 +1,3 @@
+DIST vpn-slice-0.16.1.tar.gz 30971 BLAKE2B 8b49c04cfb70d27dffd6348438c25e8826cf272d3de197fc75a1d2275ddbf4bb5cccbeb1ba52886641afd7743d2fd40b2d0a7b8780bb80233250db25b8fdbaf0 SHA512 ba588927fd859691b768dfe2ee6e407ee133df303831d60828283b41f3bd3386f9b1f03e6df9c43191678490de68b81b0ed7c9c6853f92ab87158fa1362e26f7
+EBUILD vpn-slice-0.16.1.ebuild 557 BLAKE2B 352143efa9ffec84666ce53ed36999a5a0df1d7b82e8035a4672412c35de47eba50046f57bb41593e871eafd275554dba46ff8902cb7e8b7195e8af91f21f499 SHA512 5298dee97d9d661205aea39d679e588d784eaaa6182f419ed42f1706badbf6a0e99b7940044a51f74f318908da2ec7bed0f879d522c4abedce8a23e3b1db2c3c
+MISC metadata.xml 441 BLAKE2B 90d9785c9f4501a7cfaf742b1697a91c909734295f01f201161264bd55aba2f699edb1560f3087beaf8d25f1acc618288b3b7150a3825619e3a86124c38f7c2a SHA512 6704e1cf43525ae5c58250c993f0578c767467c576af932ffb312ffaf5fda38d5685ba4b8360c8ce29682fe3621b24e0acedb2bbdc2b600b0b1cba41b63bdd1d
diff --git a/net-vpn/vpn-slice/metadata.xml b/net-vpn/vpn-slice/metadata.xml
new file mode 100644
index 0000000..57e16f7
--- /dev/null
+++ b/net-vpn/vpn-slice/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">dlenski/vpn-slice</remote-id>
+ <bugs-to>https://github.com/dlenski/vpn-slice/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/net-vpn/vpn-slice/vpn-slice-0.16.1.ebuild b/net-vpn/vpn-slice/vpn-slice-0.16.1.ebuild
new file mode 100644
index 0000000..57d0225
--- /dev/null
+++ b/net-vpn/vpn-slice/vpn-slice-0.16.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="vpnc-script replacement for easy and secure split-tunnel VPN setup "
+HOMEPAGE="https://github.com/dlenski/vpn-slice"
+SRC_URI="https://github.com/dlenski/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+"