summaryrefslogtreecommitdiff
path: root/net-vpn/gp-saml-gui/gp-saml-gui-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-vpn/gp-saml-gui/gp-saml-gui-9999.ebuild')
-rw-r--r--net-vpn/gp-saml-gui/gp-saml-gui-9999.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/net-vpn/gp-saml-gui/gp-saml-gui-9999.ebuild b/net-vpn/gp-saml-gui/gp-saml-gui-9999.ebuild
new file mode 100644
index 0000000..a79c75f
--- /dev/null
+++ b/net-vpn/gp-saml-gui/gp-saml-gui-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Interactively authenticate to GlobalProtect VPNs that require SAML"
+HOMEPAGE="https://github.com/dlenski/gp-saml-gui"
+
+EGIT_REPO_URI="https://github.com/dlenski/gp-saml-gui.git"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ net-libs/webkit-gtk:4
+ net-vpn/openconnect
+"