summaryrefslogtreecommitdiff
path: root/dev-lua/resty-http
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/resty-http')
-rw-r--r--dev-lua/resty-http/Manifest3
-rw-r--r--dev-lua/resty-http/metadata.xml12
-rw-r--r--dev-lua/resty-http/resty-http-0.17.1.ebuild46
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-lua/resty-http/Manifest b/dev-lua/resty-http/Manifest
new file mode 100644
index 0000000..bc0b06b
--- /dev/null
+++ b/dev-lua/resty-http/Manifest
@@ -0,0 +1,3 @@
+DIST resty-http-0.17.1.tar.gz 45509 BLAKE2B 20ab49288c7f5176098dea6ba3524a04d30be2b2e323517142364c408f8c69922cc30a38171b393148c3296477cc1327d0348e74b56676b6b45e1cf1ba5cd6f1 SHA512 d2a738457fb4119a44213b1de7ad0b910ef27a03a36237911fce7cf3efa00ade0ccff303e053b13f1bb80f525862cf4138726f8aacdeedb320b524e1691d1eee
+EBUILD resty-http-0.17.1.ebuild 895 BLAKE2B 4616017c79b75b13d4211a5f7c4f5bafa675c65d578d4dde4e7c8683b5529d67fdc38fb7e4b229bb8cff16206de6b469f71f3771e4138e213e055b83f9d350b5 SHA512 709c0ce331d7ee7c3495a082061f08c76d9627ec95b802c6b47f24754a077440b682f96b357c8f24a482a3001ba04c26337d97fe66a6e0f9ee19f998e1188194
+MISC metadata.xml 425 BLAKE2B da55dcd69357274d0921029f6f6265b34d83e5f12a7c70e4eed61749fbc290957305b7341eacaf3dc927774c0448c4b94eed9d182337f9d04602ac0277f6268c SHA512 617f34f7cb402c248d9b467758d899e3224abd7a4042d264a700430f8534f4eb1606f641a3060939fbccc62d871b829b01a9cb6691461e7fa1fbc20ccce353a9
diff --git a/dev-lua/resty-http/metadata.xml b/dev-lua/resty-http/metadata.xml
new file mode 100644
index 0000000..718dcf0
--- /dev/null
+++ b/dev-lua/resty-http/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/openresty/lua-resty-lrucache/issues</bugs-to>
+ <remote-id type="github">openresty/lua-resty-lrucache</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-lua/resty-http/resty-http-0.17.1.ebuild b/dev-lua/resty-http/resty-http-0.17.1.ebuild
new file mode 100644
index 0000000..af67ee7
--- /dev/null
+++ b/dev-lua/resty-http/resty-http-0.17.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( luajit )
+
+inherit lua
+
+DESCRIPTION="Lua HTTP client cosocket driver for OpenResty / ngx_lua"
+HOMEPAGE="https://github.com/ledgetech/lua-resty-http"
+
+if [[ "${PV}" =~ 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ledgetech/lua-resty-http"
+else
+ SRC_URI="https://github.com/ledgetech/lua-resty-http/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/lua-${P}"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+IUSE="+lua_targets_luajit"
+
+RDEPEND="
+ ${LUA_DEPS}
+ www-servers/nginx:*[nginx_modules_http_lua]
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+each_lua_install() {
+ insinto "$(lua_get_lmod_dir)"
+ doins -r lib/resty
+}
+
+src_compile() { :; }
+
+src_install() {
+ lua_foreach_impl each_lua_install
+ einstalldocs
+}