summaryrefslogtreecommitdiff
path: root/dev-lua
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/resty-core/Manifest3
-rw-r--r--dev-lua/resty-core/resty-core-0.1.27.ebuild53
-rw-r--r--dev-lua/resty-http/Manifest3
-rw-r--r--dev-lua/resty-http/metadata.xml12
-rw-r--r--dev-lua/resty-http/resty-http-0.17.1.ebuild46
5 files changed, 117 insertions, 0 deletions
diff --git a/dev-lua/resty-core/Manifest b/dev-lua/resty-core/Manifest
index 98da599..c2fa8fb 100644
--- a/dev-lua/resty-core/Manifest
+++ b/dev-lua/resty-core/Manifest
@@ -1,2 +1,5 @@
DIST resty-core-0.1.23.tar.gz 169382 BLAKE2B 4a357f3d3f1333e53761cfeabb13b3202baae0d98f89afd5d1f7f7890ddaddc74103e0635a0756d9f8b069a18218ec61ed99d29ef2b323f2dbf27ed21bfb1f9b SHA512 eccae9705217583deca292cd2cb4b7ac03a304926257d1e62a9434c0a08d5fa31546f7d7f196b40c29cad2c560e48daa78d558a11083c9598f7e5242f6099105
+DIST resty-core-0.1.27.tar.gz 187745 BLAKE2B 5ab4c449527ff3aa31dbf9f3cb89a5c9f5034f4a08faf2a6736cc6ad10c44362212b1388d64c3e1412de54cd809bfc6a0fecdd7b0b116aad74fd2684e86b4c51 SHA512 1734c3980fa062fadc939e257720cb3af32e4155cd94b15d1efdf5873e99a2bff54473142c85c1f0dbf247d549a95a9dc4eaa5a0abf4bc5d4539d00e2c81ca67
EBUILD resty-core-0.1.23.ebuild 1046 BLAKE2B 596fd061bbba51ca0d0da644aea14cca7096abfdb953fee3eff84d8900a5b60399df3a30ac81fd52204fca4622049ebe32a36e24a602565cedc3326f333034d8 SHA512 7a7922ebaee60f32157546eb9512a1cc9f2b7840666bff56cc0dc63b895afe66e250cb1cee8f18698fd55c4af67cfd038a057a42408f81aa870f140f4d3a95f0
+EBUILD resty-core-0.1.27.ebuild 1062 BLAKE2B 6dd8b5faf93e25c026a8a3000dfc4b01840ad735dd3ae49d078687ba1c63e7666c6d27be33454274e30aa317eceb53aad73682ca128b9be03b474370f9728c6c SHA512 2d8d969e977e8a945f5b8875c74417cffd7d2b409f0b5c239ae2a1415c0eda119accc4602d91ba763b3f35e96edeab5611f1bf3b17fcb566caeb42ed6ec1261c
+MISC metadata.xml 417 BLAKE2B c212978549fdcc84e1b47b1e63672b2a764753c9bac3518c38e0b88d1e6511df63a034581d1532e85fb5c29e53a6bad2b79d7eb7eb80c1a849f7e9b2c05064b2 SHA512 701b670c21b0d8e67be0f0eb57404e6e4b1f2250034037c2d111361566841ce740b67da10b649843698ae58b0711e7a252cba48c2c779efb78da903b7c9f2995
diff --git a/dev-lua/resty-core/resty-core-0.1.27.ebuild b/dev-lua/resty-core/resty-core-0.1.27.ebuild
new file mode 100644
index 0000000..b725ae9
--- /dev/null
+++ b/dev-lua/resty-core/resty-core-0.1.27.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( luajit )
+
+inherit lua
+
+DESCRIPTION="New LuaJIT FFI based API for lua-nginx-module"
+HOMEPAGE="https://github.com/openresty/lua-resty-core"
+
+if [[ "${PV}" =~ 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/openresty/lua-resty-core"
+else
+ SRC_URI="https://github.com/openresty/lua-resty-core/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/lua-${P}"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+IUSE="+lua_targets_luajit"
+
+RDEPEND="
+ ${LUA_DEPS}
+ >=www-servers/nginx-1.25.1-r2[nginx_modules_http_lua,lua_single_target_luajit]
+ dev-lua/resty-lrucache[${LUA_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+DOCS+=(docs/.)
+
+src_prepare() {
+ default
+ mkdir -p docs
+ find . -type f -name '*.md' -exec mv -t docs {} ';'
+}
+
+each_lua_install() {
+ insinto "$(lua_get_lmod_dir)"
+ doins -r lib/resty lib/ngx
+}
+
+src_install() {
+ einstalldocs
+ lua_foreach_impl each_lua_install
+}
diff --git a/dev-lua/resty-http/Manifest b/dev-lua/resty-http/Manifest
new file mode 100644
index 0000000..bc0b06b
--- /dev/null
+++ b/dev-lua/resty-http/Manifest
@@ -0,0 +1,3 @@
+DIST resty-http-0.17.1.tar.gz 45509 BLAKE2B 20ab49288c7f5176098dea6ba3524a04d30be2b2e323517142364c408f8c69922cc30a38171b393148c3296477cc1327d0348e74b56676b6b45e1cf1ba5cd6f1 SHA512 d2a738457fb4119a44213b1de7ad0b910ef27a03a36237911fce7cf3efa00ade0ccff303e053b13f1bb80f525862cf4138726f8aacdeedb320b524e1691d1eee
+EBUILD resty-http-0.17.1.ebuild 895 BLAKE2B 4616017c79b75b13d4211a5f7c4f5bafa675c65d578d4dde4e7c8683b5529d67fdc38fb7e4b229bb8cff16206de6b469f71f3771e4138e213e055b83f9d350b5 SHA512 709c0ce331d7ee7c3495a082061f08c76d9627ec95b802c6b47f24754a077440b682f96b357c8f24a482a3001ba04c26337d97fe66a6e0f9ee19f998e1188194
+MISC metadata.xml 425 BLAKE2B da55dcd69357274d0921029f6f6265b34d83e5f12a7c70e4eed61749fbc290957305b7341eacaf3dc927774c0448c4b94eed9d182337f9d04602ac0277f6268c SHA512 617f34f7cb402c248d9b467758d899e3224abd7a4042d264a700430f8534f4eb1606f641a3060939fbccc62d871b829b01a9cb6691461e7fa1fbc20ccce353a9
diff --git a/dev-lua/resty-http/metadata.xml b/dev-lua/resty-http/metadata.xml
new file mode 100644
index 0000000..718dcf0
--- /dev/null
+++ b/dev-lua/resty-http/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/openresty/lua-resty-lrucache/issues</bugs-to>
+ <remote-id type="github">openresty/lua-resty-lrucache</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-lua/resty-http/resty-http-0.17.1.ebuild b/dev-lua/resty-http/resty-http-0.17.1.ebuild
new file mode 100644
index 0000000..af67ee7
--- /dev/null
+++ b/dev-lua/resty-http/resty-http-0.17.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( luajit )
+
+inherit lua
+
+DESCRIPTION="Lua HTTP client cosocket driver for OpenResty / ngx_lua"
+HOMEPAGE="https://github.com/ledgetech/lua-resty-http"
+
+if [[ "${PV}" =~ 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ledgetech/lua-resty-http"
+else
+ SRC_URI="https://github.com/ledgetech/lua-resty-http/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/lua-${P}"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+IUSE="+lua_targets_luajit"
+
+RDEPEND="
+ ${LUA_DEPS}
+ www-servers/nginx:*[nginx_modules_http_lua]
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+each_lua_install() {
+ insinto "$(lua_get_lmod_dir)"
+ doins -r lib/resty
+}
+
+src_compile() { :; }
+
+src_install() {
+ lua_foreach_impl each_lua_install
+ einstalldocs
+}