summaryrefslogtreecommitdiff
path: root/dev-lua/resty-http/resty-http-0.17.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/resty-http/resty-http-0.17.1.ebuild')
-rw-r--r--dev-lua/resty-http/resty-http-0.17.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-lua/resty-http/resty-http-0.17.1.ebuild b/dev-lua/resty-http/resty-http-0.17.1.ebuild
new file mode 100644
index 0000000..af67ee7
--- /dev/null
+++ b/dev-lua/resty-http/resty-http-0.17.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( luajit )
+
+inherit lua
+
+DESCRIPTION="Lua HTTP client cosocket driver for OpenResty / ngx_lua"
+HOMEPAGE="https://github.com/ledgetech/lua-resty-http"
+
+if [[ "${PV}" =~ 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ledgetech/lua-resty-http"
+else
+ SRC_URI="https://github.com/ledgetech/lua-resty-http/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/lua-${P}"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+IUSE="+lua_targets_luajit"
+
+RDEPEND="
+ ${LUA_DEPS}
+ www-servers/nginx:*[nginx_modules_http_lua]
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+each_lua_install() {
+ insinto "$(lua_get_lmod_dir)"
+ doins -r lib/resty
+}
+
+src_compile() { :; }
+
+src_install() {
+ lua_foreach_impl each_lua_install
+ einstalldocs
+}