summaryrefslogtreecommitdiff
path: root/net-mail/mhonarc
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/mhonarc')
-rw-r--r--net-mail/mhonarc/Manifest3
-rw-r--r--net-mail/mhonarc/metadata.xml12
-rw-r--r--net-mail/mhonarc/mhonarc-2.6.24.ebuild30
3 files changed, 45 insertions, 0 deletions
diff --git a/net-mail/mhonarc/Manifest b/net-mail/mhonarc/Manifest
new file mode 100644
index 0000000..56e6933
--- /dev/null
+++ b/net-mail/mhonarc/Manifest
@@ -0,0 +1,3 @@
+DIST mhonarc-2.6.24.tar.gz 1955519 BLAKE2B fb657c01b3f71cd1b90d50dc213f490d72312083ae3c174d832591715c086206901bc1660ae9987ff7c5bdb7c131bc151923e5ce3086267a8887b663ef97da02 SHA512 bb3c4ee7c5dfd731513f1f7e4bcc92d0ae437975048c297812c93b3571fc560eb87ce60a929aa2fef0e2f1c9ad7a1ce3f3520d4724d3803f89c70e5869199b41
+EBUILD mhonarc-2.6.24.ebuild 886 BLAKE2B 662ec5b903d0784953679872932ad4d4936d8eec7e5dccb0b4fc2953e961dc6531c2775ab6c36f29f3f622d6fecea181ce9ecb5ffa6f32918e5f89fcbb844038 SHA512 e79d985fd3e6ac35635d9376373f10e7c1f802344efaa4ff9653aff3feec3c41ce159c25977d21f47df0b2a0458e9e7da1f5b55a1ff271a0e853aadf3da8fba2
+MISC metadata.xml 415 BLAKE2B 8eff8b283f267659180129c55e9d772295d76486afbf499ea116d548e59045a08b18eed74ea281e149a853b8e0bef79e1595676bd6a042a725ce7185111dd763 SHA512 15e6594ce67b16268f983cf12a2a984444d2b964a3e39b1aa45131ea637550f5f2ae40b1fa0925e1f182ca51fd4cc38a5a0432807da59907fef17a0d7fe4c7e9
diff --git a/net-mail/mhonarc/metadata.xml b/net-mail/mhonarc/metadata.xml
new file mode 100644
index 0000000..d344cde
--- /dev/null
+++ b/net-mail/mhonarc/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/sympa-community/MHonArc/issues</bugs-to>
+ <remote-id type="github">sympa-community/MHonArc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-mail/mhonarc/mhonarc-2.6.24.ebuild b/net-mail/mhonarc/mhonarc-2.6.24.ebuild
new file mode 100644
index 0000000..6aa8601
--- /dev/null
+++ b/net-mail/mhonarc/mhonarc-2.6.24.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+DESCRIPTION="Perl Mail-to-HTML Converter"
+HOMEPAGE="https://www.mhonarc.org/"
+SRC_URI="https://github.com/sympa-community/MHonArc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P/mhonarc/MHonArc}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 mips ppc x86"
+# Warrants IUSE examples, and here it is + ? IUSE doc; see also extras folder with html docs
+IUSE="examples"
+
+src_install() {
+ sed -e "s|-prefix |-docpath '${D}/usr/share/doc/${PF}/html' -prefix '${D}'|g" -i Makefile ||
+ die 'sed on Makefile failed'
+ sed -e "s|installsitelib|installvendorlib|g" -i install.me ||
+ die 'sed on install.me failed'
+ perl-module_src_install
+ if use examples; then
+ docompress -x usr/share/doc/${PF}/examples
+ insinto usr/share/doc/${PF}/
+ doins -r examples/
+ fi
+}