summaryrefslogtreecommitdiff
path: root/net-mail
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mhonarc/Manifest3
-rw-r--r--net-mail/mhonarc/metadata.xml12
-rw-r--r--net-mail/mhonarc/mhonarc-2.6.24.ebuild30
-rw-r--r--net-mail/sympa/Manifest12
-rw-r--r--net-mail/sympa/files/sympa-6.2-sqlite-lowercase.patch19
-rw-r--r--net-mail/sympa/files/sympa-apache.conf23
-rw-r--r--net-mail/sympa/files/sympa-apache_soap.conf11
-rw-r--r--net-mail/sympa/files/sympa-lighttpd.conf17
-rw-r--r--net-mail/sympa/files/sympa-lighttpd_soap.conf14
-rw-r--r--net-mail/sympa/metadata.xml16
-rw-r--r--net-mail/sympa/sympa-6.2.72.ebuild (renamed from net-mail/sympa/sympa-6.2.48.ebuild)55
11 files changed, 130 insertions, 82 deletions
diff --git a/net-mail/mhonarc/Manifest b/net-mail/mhonarc/Manifest
new file mode 100644
index 0000000..56e6933
--- /dev/null
+++ b/net-mail/mhonarc/Manifest
@@ -0,0 +1,3 @@
+DIST mhonarc-2.6.24.tar.gz 1955519 BLAKE2B fb657c01b3f71cd1b90d50dc213f490d72312083ae3c174d832591715c086206901bc1660ae9987ff7c5bdb7c131bc151923e5ce3086267a8887b663ef97da02 SHA512 bb3c4ee7c5dfd731513f1f7e4bcc92d0ae437975048c297812c93b3571fc560eb87ce60a929aa2fef0e2f1c9ad7a1ce3f3520d4724d3803f89c70e5869199b41
+EBUILD mhonarc-2.6.24.ebuild 886 BLAKE2B 662ec5b903d0784953679872932ad4d4936d8eec7e5dccb0b4fc2953e961dc6531c2775ab6c36f29f3f622d6fecea181ce9ecb5ffa6f32918e5f89fcbb844038 SHA512 e79d985fd3e6ac35635d9376373f10e7c1f802344efaa4ff9653aff3feec3c41ce159c25977d21f47df0b2a0458e9e7da1f5b55a1ff271a0e853aadf3da8fba2
+MISC metadata.xml 415 BLAKE2B 8eff8b283f267659180129c55e9d772295d76486afbf499ea116d548e59045a08b18eed74ea281e149a853b8e0bef79e1595676bd6a042a725ce7185111dd763 SHA512 15e6594ce67b16268f983cf12a2a984444d2b964a3e39b1aa45131ea637550f5f2ae40b1fa0925e1f182ca51fd4cc38a5a0432807da59907fef17a0d7fe4c7e9
diff --git a/net-mail/mhonarc/metadata.xml b/net-mail/mhonarc/metadata.xml
new file mode 100644
index 0000000..d344cde
--- /dev/null
+++ b/net-mail/mhonarc/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/sympa-community/MHonArc/issues</bugs-to>
+ <remote-id type="github">sympa-community/MHonArc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-mail/mhonarc/mhonarc-2.6.24.ebuild b/net-mail/mhonarc/mhonarc-2.6.24.ebuild
new file mode 100644
index 0000000..6aa8601
--- /dev/null
+++ b/net-mail/mhonarc/mhonarc-2.6.24.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+DESCRIPTION="Perl Mail-to-HTML Converter"
+HOMEPAGE="https://www.mhonarc.org/"
+SRC_URI="https://github.com/sympa-community/MHonArc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P/mhonarc/MHonArc}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 mips ppc x86"
+# Warrants IUSE examples, and here it is + ? IUSE doc; see also extras folder with html docs
+IUSE="examples"
+
+src_install() {
+ sed -e "s|-prefix |-docpath '${D}/usr/share/doc/${PF}/html' -prefix '${D}'|g" -i Makefile ||
+ die 'sed on Makefile failed'
+ sed -e "s|installsitelib|installvendorlib|g" -i install.me ||
+ die 'sed on install.me failed'
+ perl-module_src_install
+ if use examples; then
+ docompress -x usr/share/doc/${PF}/examples
+ insinto usr/share/doc/${PF}/
+ doins -r examples/
+ fi
+}
diff --git a/net-mail/sympa/Manifest b/net-mail/sympa/Manifest
index a81e49c..b7061ed 100644
--- a/net-mail/sympa/Manifest
+++ b/net-mail/sympa/Manifest
@@ -1,8 +1,8 @@
+AUX sympa-6.2-sqlite-lowercase.patch 740 BLAKE2B 00d179c14f6d58e5889f92e418c693d462dd777bdc83397881abee9c3789a473273c41102b52f93b7ed416658a9ddb6e043ed49170312278834630f96ba2bd45 SHA512 216a22ba8c9992c6a7be108db6201424ea16f969e8595cadd5211797ed0ca6acd96cf9770fdd9529343c9dc9b23ab3e80a6d80403fd7db41b7574ef979062b2a
AUX sympa-6.2.initd 1101 BLAKE2B f367ac3730aaeda4ae8cb99bafc87291e3b2aeeecc507256ea2a3bd19a2094f6dafc00536bd8132beecd7fb214f4e25c5c0b8cfe49a28d5c14ac0f7af897286f SHA512 bf2e6fe97abf58379fe37d6cf9fa4528ccc1027217562efa9b61a66b8f6e65993f2577e5bc0ac8711d10f12ae090b848e6acd9db047cb79d3b53ea488b598940
-AUX sympa-apache.conf 307 BLAKE2B 01c2cf98a32951916e0ca2472c3ac4d30a40659d4b7c0474ce10e01b151cf69ad0c7d17cc93e540240ea386005a23de276cdc1ce2e423a101af4d8fd4b120a8e SHA512 26a132c6e8fd1aec951f5755351d2ec69c34dd213a2249cb0b995938cfdf7c1ec50fe5c11780cfb0da953ba00e9fee5c6846cc5beb486b1d6e0716d0c7695486
-AUX sympa-apache_soap.conf 332 BLAKE2B 97003842d7e4f57ab5df3a8ee7e971e1de8fc7a23787667e3ec3af6883f38f028c12d1986cc48e70503754e2dfb06bc68c167129eb7a32355407f177c6063714 SHA512 f54c45f0a5b49fb3e687a17ad8982c6f6cab667959ed92d2ee56f231b3bcf378b267adb3c32b26597c3af625e88f9dfdfe0cbe58a20153d224bb5f107b681891
-AUX sympa-lighttpd.conf 372 BLAKE2B 701e0bc7ed328257a62d29eb5899da255a5102e8fc1c199ae8769000053fc7c771b2159be86ba7fa232cb243801352719d9cf9f985f36a84b157faff70dcb673 SHA512 765ec8521fe426da3c17186a8820982388cc6678fb038473de7310d15aa789b902df2edd055e82bfc98cc7161a2728f9f685f2da5862c466635a901d47f301e5
-AUX sympa-lighttpd_soap.conf 382 BLAKE2B 08456e6603a4a2f960a818c5ab5374d03c15e5cc30aae83ad6602758d7cad857fd0b2a1995f23c37b17f3046a2f45f57e14f9b5cf7742fde0b4c23c86798d5b2 SHA512 1aac44ca4c410d90e384ac092cfbb2ead8a144ed472998266ccc9b1411e6ce6d4c02edbf46496c14585c65cfbf23cf8276901df2d54895bdf4edd3cecf447f2d
+AUX sympa-apache.conf 372 BLAKE2B db8dc96e13cb022322137f79314c24f6724fc42b2ec66c72e8c6b52f5070360d7583cda4c7ba470a62185bf253e00e705c2816151f31a879534b515d7c932913 SHA512 ec050ca4ebfac8439f7c3715e7650fa7507d6c9f2ef07d6ae0e1d9928081997fd1425afd37be9654726c25cf3fdcf651f6700fc046d83a2dfabba7908498e477
+AUX sympa-lighttpd.conf 398 BLAKE2B 7a35e360cb546ec9151ec564a245bf62a9acbb1a9f56e3ad598e1fbdd8be1405a92c1bf623a575c29cb6b09f0cc235cc34d2a6ca7ae2f38197b6bb8e667eb4b4 SHA512 8c7811d7a82c9d77aea5d20dced41c394fc8d3ec3e46c898e519d19422e4cf3fc6edce9bc9065ecf9ce08f1775b03bfd5cfac07e1ba40a3beceb8e240ba99b33
AUX sympa-nginx.conf 252 BLAKE2B 51471cdc0151a10d86b396bb7d3ecca51508d53fbcce91804c2ffcfefd6ee9170502d2cc36519eb66570371150fafa81ae7ed991d38ba901e1c4248f806d06e5 SHA512 076900022f1d6c03e26301ed15514dc922a9ba9718c8a344722ad755c5caf0277daae944959f061445f58ef163d6d243670fb97b92f06e6370a1f8621762221f
-DIST sympa-6.2.48.tar.gz 12768937 BLAKE2B 188189eac2712bdab4673ca09e4a4c37d035906524a0a73d7eac74e517906b3e63c588af4636c31c3dd861850fa0e452474ff8873f454d3dfad650c05b99afb0 SHA512 b1ff034fc9a69edae266741e3b868555040bc1c4cdba9bae901729cd23b3f310895d0a9a5fe2119373880f1b65c25cd14e6753d93ad4ff15adf377f51cc25719
-EBUILD sympa-6.2.48.ebuild 7914 BLAKE2B 357707951efbd742049f9986beafb05bf57bd1bf22d4f992dec7ce0d9f76d2a68665bf5d7b31a23b092ceec438a2a5f78acc9d740504d5c885dd79a8cd3334ed SHA512 fbf49aa7e210ad49adc0a19376361c3b66f77cc35809e71a6bb7670ef15c480e70f1ab0d43da151a7d7ffcea1c703065f8a3c8f74248d71296e44e687bb80b31
+DIST sympa-6.2.72.tar.gz 13361403 BLAKE2B b79b82be4b9633df4effd2aa8fcdc4625f2e776c182ac49c3f061174ca4f8948c3f8a78c8497b83ab949ab47eb46c29e31124412d9c5ddab3cbf518afa732244 SHA512 413dc24e17d4ffbafa58b241d71922e541c411370301195c70b0a87d2ec529e04a8f04d084e39dcae32fa7d2987573fa673a1dc742c14c917b722ff24db76291
+EBUILD sympa-6.2.72.ebuild 7359 BLAKE2B 8f9601e1912777eeb6a7e9c03ea94ca29947f13d736a409fdff0b312e094f7674023a47ee8dc90b746fcd1cffd2c156a810b985a9a4460e4ae29c9115a19121e SHA512 6f73e6083b72a9e2835db203267f6286f550b063690c2656f62069beae37b2f265e0cbe56a133edf46e7fb1ff5b213844d88afde46289276c2a59b28ae4704da
+MISC metadata.xml 557 BLAKE2B acec2d08bd6209195ef84b75d7f1ac3a6ee9ef935980249710bb50aa1df7f34bd60900a82f34b69ebbf334bf559e51cd87064445ffc73630cae764c2cfb036b6 SHA512 aa11862ddb6112b7a199222b7eb75d11d70110491ec0287419c38bb81f8f81ef7a98aaa284906910a08614e0757827bd7a6b7cd31ae603738ffd7ad213a7fbd0
diff --git a/net-mail/sympa/files/sympa-6.2-sqlite-lowercase.patch b/net-mail/sympa/files/sympa-6.2-sqlite-lowercase.patch
new file mode 100644
index 0000000..0fc5bd5
--- /dev/null
+++ b/net-mail/sympa/files/sympa-6.2-sqlite-lowercase.patch
@@ -0,0 +1,19 @@
+commit c2bb2ebc22111d808a8ecad9c05a520a939c1494
+Author: Emmanuel Bouthenot <kolter@openics.org>
+Date: Sat Nov 12 08:11:13 2022 +0100
+
+ Fix SQLite upgrade with lowercase types
+
+diff --git a/src/lib/Sympa/DatabaseDriver/SQLite.pm b/src/lib/Sympa/DatabaseDriver/SQLite.pm
+index 06d7ad627..1b42083ac 100644
+--- a/src/lib/Sympa/DatabaseDriver/SQLite.pm
++++ b/src/lib/Sympa/DatabaseDriver/SQLite.pm
+@@ -191,7 +191,7 @@ sub get_fields {
+ }
+ while (my $field = $sth->fetchrow_hashref('NAME_lc')) {
+ # http://www.sqlite.org/datatype3.html
+- my $type = $field->{'type'};
++ my $type = lc $field->{'type'};
+ if ($type =~ /int/) {
+ $type = 'integer';
+ } elsif ($type =~ /char|clob|text/) {
diff --git a/net-mail/sympa/files/sympa-apache.conf b/net-mail/sympa/files/sympa-apache.conf
index 94098f8..1d652c1 100644
--- a/net-mail/sympa/files/sympa-apache.conf
+++ b/net-mail/sympa/files/sympa-apache.conf
@@ -1,11 +1,14 @@
-Alias /static-sympa /var/spool/sympa/static_content
+LoadModule alias_module modules/mod_alias.so
+LoadModule proxy_module modules/mod_proxy.so
+LoadModule proxy_fcgi_module modules/mod_proxy_fcgi.so
+
+<Location /sympa>
+ SetHandler "proxy:unix:/var/run/sympa.sock|fcgi://"
+ Require all granted
+</Location>
-<IfDefine SYMPA>
- ScriptAlias /sympa /usr/libexec/sympa/wwsympa-wrapper.fcgi
- <IfDefine FASTCGI>
- FastCgiServer /usr/libexec/sympa/wwsympa-wrapper.fcgi -processes 2
- <Location /sympa>
- SetHandler fastcgi-script
- </Location>
- </Ifdefine>
-</Ifdefine>
+<Location /static-sympa>
+ Require all granted
+</Location>
+
+Alias /static-sympa /var/spool/sympa/static_content
diff --git a/net-mail/sympa/files/sympa-apache_soap.conf b/net-mail/sympa/files/sympa-apache_soap.conf
deleted file mode 100644
index 553df34..0000000
--- a/net-mail/sympa/files/sympa-apache_soap.conf
+++ /dev/null
@@ -1,11 +0,0 @@
-Alias /static-sympa /var/spool/sympa/static_content
-
-<IfDefine SYMPA_SOAP>
- ScriptAlias /sympa /usr/libexec/sympa/sympa_soap_server-wrapper.fcgi
- <IfDefine FASTCGI>
- FastCgiServer /usr/libexec/sympa/sympa_soap_server-wrapper.fcgi -processes 2
- <Location /sympa>
- SetHandler fastcgi-script
- </Location>
- </Ifdefine>
-</Ifdefine>
diff --git a/net-mail/sympa/files/sympa-lighttpd.conf b/net-mail/sympa/files/sympa-lighttpd.conf
index 7023086..ce072c5 100644
--- a/net-mail/sympa/files/sympa-lighttpd.conf
+++ b/net-mail/sympa/files/sympa-lighttpd.conf
@@ -1,14 +1,15 @@
server.modules += ("mod_fastcgi")
+server.modules += ("mod_alias")
alias.url += ( "/static-sympa/" => "/var/spool/sympa/static_content/" )
$HTTP["url"] =~ "^/sympa" {
-fastcgi.server = ( "/sympa" =>
- (( "check-local" => "disable",
- "bin-path" => "/usr/libexec/sympa/wwsympa-wrapper.fcgi",
- "socket" => "/var/run/lighttpd/sympa.sock",
- "max-procs" => 2,
- "idle-timeout" => 20,
- ))
- )
+ fastcgi.server = ( "/sympa" =>
+ (( "check-local" => "disable",
+ "bin-path" => "/usr/libexec/sympa/wwsympa-wrapper.fcgi",
+ "socket" => "/var/run/lighttpd/sympa.sock",
+ "max-procs" => 2,
+ "idle-timeout" => 20,
+ ))
+ )
}
diff --git a/net-mail/sympa/files/sympa-lighttpd_soap.conf b/net-mail/sympa/files/sympa-lighttpd_soap.conf
deleted file mode 100644
index 121114f..0000000
--- a/net-mail/sympa/files/sympa-lighttpd_soap.conf
+++ /dev/null
@@ -1,14 +0,0 @@
-server.modules += ("mod_fastcgi")
-
-alias.url += ( "/static-sympa/" => "/var/spool/sympa/static_content/" )
-
-$HTTP["url"] =~ "^/sympa" {
-fastcgi.server = ( "/sympa" =>
- (( "check-local" => "disable",
- "bin-path" => "/usr/libexec/sympa/sympa_soap_server-wrapper.fcgi",
- "socket" => "/var/run/lighttpd/sympa.sock",
- "max-procs" => 2,
- "idle-timeout" => 20,
- ))
- )
-}
diff --git a/net-mail/sympa/metadata.xml b/net-mail/sympa/metadata.xml
new file mode 100644
index 0000000..2bf31b8
--- /dev/null
+++ b/net-mail/sympa/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <use>
+ <flag name="compat">Enable migration compatibility flag</flag>
+ <flag name="dkim">Add DomainKeys Identified Mail support</flag>
+ </use>
+ <upstream>
+ <bugs-to>https://github.com/sympa-community/sympa/issues</bugs-to>
+ <remote-id type="github">sympa-community/sympa</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-mail/sympa/sympa-6.2.48.ebuild b/net-mail/sympa/sympa-6.2.72.ebuild
index 2b4fe71..7e76d7a 100644
--- a/net-mail/sympa/sympa-6.2.48.ebuild
+++ b/net-mail/sympa/sympa-6.2.72.ebuild
@@ -1,16 +1,15 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit eutils user multilib autotools
+inherit autotools
SYMPA_VERSION="$(ver_cut 1-2)"
SYMPA_RELEASE="$(ver_cut 3-)"
if [[ ${SYMPA_VERSION} == "9999" ]] ; then
# Development version
- SRC_URI=""
EGIT_REPO_URI="https://github.com/sympa-community/sympa"
inherit git-r3
elif [[ ${SYMPA_RELEASE} == "9999" ]] ; then
@@ -24,16 +23,20 @@ else
fi
DESCRIPTION="A feature-rich open source mailing list software"
-HOMEPAGE="https://www.sympa.org/"
+HOMEPAGE="https://www.sympa.community/"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="clamav -compat dkim fastcgi ldap mysql nls postgres soap sqlite ssl"
+IUSE="clamav compat dkim fastcgi ldap mysql nls postgres soap +sqlite ssl"
REQUIRED_USE="|| ( mysql postgres sqlite )"
-# See https://www.sympa.org/manual/installing-sympa#required_cpan_modules
+ACCT_DEPEND="
+ acct-group/sympa
+ acct-user/sympa
+"
RDEPEND="
+ ${ACCT_DEPEND}
>=dev-lang/perl-5.8
>=dev-perl/CGI-3.51
>=virtual/perl-Digest-MD5-2.00
@@ -71,7 +74,7 @@ RDEPEND="
>=dev-perl/XML-LibXML-1.70
>=dev-perl/libintl-perl-1.20
dev-perl/libwww-perl
- >=net-mail/mhonarc-2.6.18
+ >=net-mail/mhonarc-2.6.24
clamav? ( app-antivirus/clamav )
compat? ( >=dev-perl/Crypt-CipherSaber-0.50 )
dkim? ( >=dev-perl/Mail-DKIM-0.37 )
@@ -94,14 +97,6 @@ DEPEND="${RDEPEND}
sys-devel/gettext
"
-SYMPA_USER="sympa"
-SYMPA_GROUP="sympa"
-
-pkg_setup() {
- enewgroup ${SYMPA_GROUP}
- enewuser ${SYMPA_USER} -1 -1 -1 ${SYMPA_GROUP}
-}
-
src_prepare() {
default
# Override defaults for certain options, so
@@ -139,8 +134,9 @@ src_configure() {
--without-initdir \
--with-unitsdir=/usr/lib/systemd/system \
--with-defaultdir=/usr/share/sympa/default \
- --with-user=${SYMPA_USER} \
- --with-group=${SYMPA_GROUP} \
+ --with-user=sympa \
+ --with-group=sympa \
+ --disable-setuid \
$(use_enable nls) \
|| die "econf failed"
}
@@ -154,14 +150,9 @@ src_install() {
# Do not overwrite data_structure.version
rm -f "${D}/etc/sympa/data_structure.version"
- # Set permissions and ownership on config files
- fowners root:${SYMPA_GROUP} /etc/sympa/sympa.conf
- fperms u=rwX,g=rX,o= /etc/sympa/sympa.conf
- # Elevate some permissions to read config files
- fperms g+s /usr/libexec/sympa/{bouncequeue,familyqueue,queue}
# Docs
- dodoc AUTHORS.md CONTRIBUTING.md INSTALL.md NEWS.md README.md etc_README
+ dodoc AUTHORS.md CONTRIBUTING.md INSTALL.md NEWS.md README.md
# Startup script
newinitd "${FILESDIR}/${PN}-${SYMPA_VERSION}.initd" "${PN}"
@@ -206,7 +197,7 @@ src_install() {
local DIR
for DIR in ${SYMPA_DIRS}; do
keepdir /var/spool/sympa/${DIR}
- fowners ${SYMPA_USER}:${SYMPA_GROUP} /var/spool/sympa/${DIR}
+ fowners sympa:sympa /var/spool/sympa/${DIR}
case "${DIR}" in
static_content*)
fperms 755 /var/spool/sympa/${DIR}
@@ -220,9 +211,7 @@ src_install() {
keepdir /var/lib/sympa/lists
newdoc "${FILESDIR}/${PN}-apache.conf" apache.conf
- newdoc "${FILESDIR}/${PN}-apache_soap.conf" apache_soap.conf
newdoc "${FILESDIR}/${PN}-lighttpd.conf" lighttpd.conf
- newdoc "${FILESDIR}/${PN}-lighttpd_soap.conf" lighttpd_soap.conf
newdoc "${FILESDIR}/${PN}-nginx.conf" nginx.conf
}
@@ -234,7 +223,7 @@ pkg_postinst() {
elog
elog "The Sympa web interface needs to be setup in your webserver."
elog "For more information please consult Sympa documentation at"
- elog "https://www.sympa.org/manual/web-interface#web_server_setup"
+ elog "https://www.sympa.org/manual/install/configure-http-server.md"
elog "Sample configs are installed in /usr/share/doc/${P}"
elog
@@ -245,22 +234,22 @@ pkg_postinst() {
elog "To use it you need to do the following:"
elog
elog "# gpasswd -a clamav sympa"
- elog "# /etc/init.d/clamd restart"
+ elog "# systemctl restart clamd.service"
elog
fi
ewarn "If you are upgrading from an earlier version please run:"
ewarn
- ewarn "# sympa.pl --upgrade"
+ ewarn "# sympa upgrade"
ewarn
ewarn "If you are upgrading from version 5.x make sure"
ewarn "compat use flag is set while emerging, then run:"
ewarn
- ewarn "# sympa.pl --upgrade"
+ ewarn "# sympa upgrade"
ewarn
ewarn "to upgrade your data structures and"
ewarn
- ewarn "# sympa.pl --md5_encode_password"
+ ewarn "# /usr/share/sympa/scripts/upgrade_sympa_password.pl"
ewarn
ewarn "to convert your passwords. When completed compat use flag"
ewarn "can be removed"