summaryrefslogtreecommitdiff
path: root/games-fps
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/armyops/Manifest3
-rw-r--r--games-fps/armyops/armyops-250.ebuild66
-rw-r--r--games-fps/armyops/metadata.xml11
3 files changed, 50 insertions, 30 deletions
diff --git a/games-fps/armyops/Manifest b/games-fps/armyops/Manifest
index 1fb9a02..0a298d1 100644
--- a/games-fps/armyops/Manifest
+++ b/games-fps/armyops/Manifest
@@ -1,2 +1,3 @@
DIST armyops250-linux.run 813453963 BLAKE2B 18bcb681d63981fef223b2705e504bd59b921bd5430c8689e528f4e1e5ccf623f22045ce554d75bdff21bfd449f4736cd16a967b6b1d0efc8052352dc61b7e5c SHA512 ed4295c0d4756ae9df76b78620922752e9edeaf41b3d056d9d186b8f594288b3c637223959073d3a1ba4011f6b50db4b4b43d56e6d63880e40c94e3fdfccd215
-EBUILD armyops-250.ebuild 1587 BLAKE2B 08b13a08c0d0edc61fbd89569fe845f11a9b21df176fdba63493047c8e1f63641e6fd3444c98702ea65e5f5b696174ae876987de3c5d55dfe7d3a26762ae8da0 SHA512 cb1fef6c61e21060241d45ec2a0c929963fce23e221430bfeeefe687086f44cf8bab6ba37aedb4dca9dffa68c9f75257aa3c729a777d4813b2f4a0a03cf8bd69
+EBUILD armyops-250.ebuild 1845 BLAKE2B 6cb442c605c9ad5715dc1e48939eacaa6a48e9ddbe610f85355d7450a70082431a8507ca254ee48b2fa04e26f746d82e5ebb3bd24bdaa7e0dbb52d0dd434df48 SHA512 e326d2cff879018a997ef877e0386b00bba27fe1b37497df16526d8e170b34f59bfe42e8a9526b23e10b77154d4417dd0ac39d6eabc028da83f1dd7398856d7a
+MISC metadata.xml 337 BLAKE2B 1ec9d883b155b55169f3e63ce6bb20a4046dd0937b8b36e4cc2a0e88daca7760ac9b7fd4ecf1b722564e5d948cdcd64da65a39e5c9450dd572646d420e16b4a6 SHA512 01a6b79265e4d4ba315d4f9a34e25fe71652e97382cf2ff8e5e89be5688542dfaaaa1c8bf25ebca0a6c21a1879b14c52d4bd0b3e1300a8893d5b56d8c4bb699c
diff --git a/games-fps/armyops/armyops-250.ebuild b/games-fps/armyops/armyops-250.ebuild
index cc3b6ae..8f30518 100644
--- a/games-fps/armyops/armyops-250.ebuild
+++ b/games-fps/armyops/armyops-250.ebuild
@@ -1,27 +1,48 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-inherit eutils unpacker games
+EAPI=8
+
+inherit check-reqs desktop unpacker wrapper
DESCRIPTION="Military simulations by the U.S. Army to provide insights on soldiering"
-HOMEPAGE="http://www.americasarmy.com/"
-SRC_URI="mirror://sourceforge/distrobuild/${PN}${PV}-linux.run"
+HOMEPAGE="https://www.americasarmy.com/"
+SRC_URI="https://downloads.sourceforge.net/project/distrobuild/sources/${PN}${PV}-linux.run"
+S=${WORKDIR}
LICENSE="Army-EULA"
SLOT="0"
-KEYWORDS="amd64 x86"
-RESTRICT="mirror strip"
-IUSE="opengl"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist mirror strip"
-RDEPEND="sys-libs/glibc"
+RDEPEND="
+ amd64? ( sys-libs/glibc[multilib] )
+ app-crypt/libmd[abi_x86_32(-)]
+ dev-libs/libbsd[abi_x86_32(-)]
+ sys-libs/glibc
+ sys-libs/libstdc++-v3:5
+ virtual/opengl[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXdmcp[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ x11-libs/libxcb[abi_x86_32(-)]
+"
-S=${WORKDIR}
+dir=opt/${PN}
+
+QA_PREBUILT="${dir}/System/*-bin ${dir}/System/*.so ${dir}/System/libSDL-1.2.so.0 ${dir}/System/pb/*.so"
+
+pre_build_checks() {
+ CHECKREQS_DISK_BUILD="3G"
+ check-reqs_pkg_setup
+}
+
+pkg_pretend() {
+ pre_build_checks
+}
pkg_setup() {
- games_pkg_setup
- einfo "The installed game takes about 1.6GB of space when installed and"
- einfo "2.4GB of space in ${PORTAGE_TMPDIR} to build!"
- echo
+ pre_build_checks
}
src_unpack() {
@@ -30,7 +51,7 @@ src_unpack() {
}
src_install() {
- local dir=${GAMES_PREFIX_OPT}/${PN}
+ local dir=/opt/${PN}
local Ddir=${D}/${dir}
einfo "This will take a while... go get a pizza or something."
@@ -47,19 +68,6 @@ src_install() {
doexe bin/armyops || die "doexe failed"
fperms ug+x "${dir}"/System/pb/pbweb.x86
- if use opengl ; then
- games_make_wrapper armyops ./armyops "${dir}" "${dir}"
- make_desktop_entry armyops "America's Army" armyops.xpm
- fi
-
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
-
- if use opengl ; then
- elog "To play the game, run: armyops"
- echo
- fi
+ make_wrapper armyops ./armyops "${dir}" "${dir}"
+ make_desktop_entry armyops "America's Army" armyops.xpm
}
diff --git a/games-fps/armyops/metadata.xml b/games-fps/armyops/metadata.xml
new file mode 100644
index 0000000..63e689a
--- /dev/null
+++ b/games-fps/armyops/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">distrobuild</remote-id>
+ </upstream>
+</pkgmetadata>