summaryrefslogtreecommitdiff
path: root/games-fps/armyops/armyops-250.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/armyops/armyops-250.ebuild')
-rw-r--r--games-fps/armyops/armyops-250.ebuild65
1 files changed, 37 insertions, 28 deletions
diff --git a/games-fps/armyops/armyops-250.ebuild b/games-fps/armyops/armyops-250.ebuild
index cc3b6ae..65c09e0 100644
--- a/games-fps/armyops/armyops-250.ebuild
+++ b/games-fps/armyops/armyops-250.ebuild
@@ -1,27 +1,49 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-inherit eutils unpacker games
+EAPI=8
+
+inherit check-reqs desktop unpacker wrapper
DESCRIPTION="Military simulations by the U.S. Army to provide insights on soldiering"
-HOMEPAGE="http://www.americasarmy.com/"
-SRC_URI="mirror://sourceforge/distrobuild/${PN}${PV}-linux.run"
+HOMEPAGE="https://www.americasarmy.com/"
+SRC_URI="mirror://sourceforge/project/distrobuild/sources/${PN}${PV}-linux.run"
LICENSE="Army-EULA"
SLOT="0"
-KEYWORDS="amd64 x86"
-RESTRICT="mirror strip"
-IUSE="opengl"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist mirror strip"
-RDEPEND="sys-libs/glibc"
+RDEPEND="
+ amd64? ( sys-libs/glibc[multilib] )
+ app-crypt/libmd[abi_x86_32(-)]
+ dev-libs/libbsd[abi_x86_32(-)]
+ sys-libs/glibc
+ sys-libs/libstdc++-v3:5
+ virtual/opengl[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXdmcp[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ x11-libs/libxcb[abi_x86_32(-)]
+"
S=${WORKDIR}
+dir=opt/${PN}
+
+QA_PREBUILT="${dir}/System/*-bin ${dir}/System/*.so ${dir}/System/libSDL-1.2.so.0 ${dir}/System/pb/*.so"
+
+pre_build_checks() {
+ CHECKREQS_DISK_BUILD="3G"
+ check-reqs_pkg_setup
+}
+
+pkg_pretend() {
+ pre_build_checks
+}
+
pkg_setup() {
- games_pkg_setup
- einfo "The installed game takes about 1.6GB of space when installed and"
- einfo "2.4GB of space in ${PORTAGE_TMPDIR} to build!"
- echo
+ pre_build_checks
}
src_unpack() {
@@ -30,7 +52,7 @@ src_unpack() {
}
src_install() {
- local dir=${GAMES_PREFIX_OPT}/${PN}
+ local dir=/opt/${PN}
local Ddir=${D}/${dir}
einfo "This will take a while... go get a pizza or something."
@@ -47,19 +69,6 @@ src_install() {
doexe bin/armyops || die "doexe failed"
fperms ug+x "${dir}"/System/pb/pbweb.x86
- if use opengl ; then
- games_make_wrapper armyops ./armyops "${dir}" "${dir}"
- make_desktop_entry armyops "America's Army" armyops.xpm
- fi
-
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
-
- if use opengl ; then
- elog "To play the game, run: armyops"
- echo
- fi
+ make_wrapper armyops ./armyops "${dir}" "${dir}"
+ make_desktop_entry armyops "America's Army" armyops.xpm
}