summaryrefslogtreecommitdiff
path: root/app-portage/epm/epm-1.40.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/epm/epm-1.40.ebuild')
-rw-r--r--app-portage/epm/epm-1.40.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/app-portage/epm/epm-1.40.ebuild b/app-portage/epm/epm-1.40.ebuild
index a407502..f840603 100644
--- a/app-portage/epm/epm-1.40.ebuild
+++ b/app-portage/epm/epm-1.40.ebuild
@@ -1,31 +1,28 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=8
-inherit eutils prefix
+inherit git-r3 prefix
DESCRIPTION="rpm workalike for Gentoo Linux"
HOMEPAGE="https://github.com/fuzzyray/epm"
-S="${WORKDIR}/"
+
+EGIT_REPO_URI="https://github.com/ganto/epm.git"
+EGIT_COMMIT="df329631d9be14305a5cc5484a03c06012a9cc0f"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-PATCHES=(
- "${FILESDIR}/${P}-prefix.patch"
-)
DEPEND="dev-lang/perl"
RDEPEND="${DEPEND}"
src_unpack() {
- :
+ git-r3_src_unpack
}
src_prepare() {
- cp "${FILESDIR}"/epm "${S}"/epm
eprefixify epm
eapply_user
}