summaryrefslogtreecommitdiff
path: root/www-apps/ttyd/ttyd-1.7.3.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2023-04-23 15:08:12 +0200
committerMarcin Deranek <marcin.deranek@booking.com>2023-04-23 15:08:24 +0200
commit568402d9adc6ed574ccc9545380dbf128f9d41d7 (patch)
tree3f3ebc1fbbf2a64f9def6f702817b025e2476d77 /www-apps/ttyd/ttyd-1.7.3.ebuild
parentc7ab3870d0d07fe24ce0dfdd3c480b8dc9799b1b (diff)
downloadportage-568402d9adc6ed574ccc9545380dbf128f9d41d7.tar.gz
portage-568402d9adc6ed574ccc9545380dbf128f9d41d7.tar.bz2
portage-568402d9adc6ed574ccc9545380dbf128f9d41d7.zip
www-apps/ttyd: New ebuild
Diffstat (limited to 'www-apps/ttyd/ttyd-1.7.3.ebuild')
-rw-r--r--www-apps/ttyd/ttyd-1.7.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/www-apps/ttyd/ttyd-1.7.3.ebuild b/www-apps/ttyd/ttyd-1.7.3.ebuild
new file mode 100644
index 0000000..e94c231
--- /dev/null
+++ b/www-apps/ttyd/ttyd-1.7.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake systemd
+
+DESCRIPTION="Share your terminal over the web"
+HOMEPAGE="https://github.com/tsl0922/ttyd"
+SRC_URI="https://github.com/tsl0922/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/json-c:=
+ dev-libs/libuv:=
+ dev-libs/openssl:=
+ net-libs/libwebsockets:=[libuv,ssl]
+ sys-libs/zlib:=
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake_src_install
+
+ systemd_dounit "${FILESDIR}"/ttyd.service
+ newinitd "${FILESDIR}"/ttyd.initd ttyd
+ newconfd "${FILESDIR}"/ttyd.confd ttyd
+}