summaryrefslogtreecommitdiff
path: root/www-apps
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2023-04-23 15:08:12 +0200
committerMarcin Deranek <marcin.deranek@booking.com>2023-04-23 15:08:24 +0200
commit568402d9adc6ed574ccc9545380dbf128f9d41d7 (patch)
tree3f3ebc1fbbf2a64f9def6f702817b025e2476d77 /www-apps
parentc7ab3870d0d07fe24ce0dfdd3c480b8dc9799b1b (diff)
downloadportage-568402d9adc6ed574ccc9545380dbf128f9d41d7.tar.gz
portage-568402d9adc6ed574ccc9545380dbf128f9d41d7.tar.bz2
portage-568402d9adc6ed574ccc9545380dbf128f9d41d7.zip
www-apps/ttyd: New ebuild
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/ttyd/Manifest6
-rw-r--r--www-apps/ttyd/files/ttyd.confd4
-rw-r--r--www-apps/ttyd/files/ttyd.initd14
-rw-r--r--www-apps/ttyd/files/ttyd.service11
-rw-r--r--www-apps/ttyd/metadata.xml12
-rw-r--r--www-apps/ttyd/ttyd-1.7.3.ebuild31
6 files changed, 78 insertions, 0 deletions
diff --git a/www-apps/ttyd/Manifest b/www-apps/ttyd/Manifest
new file mode 100644
index 0000000..fac42d0
--- /dev/null
+++ b/www-apps/ttyd/Manifest
@@ -0,0 +1,6 @@
+AUX ttyd.confd 117 BLAKE2B 6214af70adf083699c5be145152eb6bf014b473765d46d09fe3a8276b738ca475330bdad87e4300927923ef02397d2621fd419ed5cd20820b309080e28c02c35 SHA512 b55bb401c77e0ffe018aea13975827f01635a40d816148fa1bd5165847226b6622ed0c49b5467909750618281f3cd07bd1aab3de14dc5129e58d4cff1405e3a9
+AUX ttyd.initd 292 BLAKE2B cb58350179d69307ed3577bdc234d88e682a6dc720ac7724b560b6713d4447599b6b1848696b065824d0619bcd4f23277fbb011c0a95b73db990afcac2d25cd1 SHA512 67b72eabe7b8105bced6954eb1fee7c571be4eb51e9f3e32f2a0865373ebeeb6e11d36f44b7b603b99ef73f794103a93561f4c521a0497c7f63ffa4b0841709d
+AUX ttyd.service 195 BLAKE2B 2f802784bb535d28cd78723d98e1591f599d45aff0726f465054103403197965e6d07da5198e64992b6b2c51bf684bf5a19a66ea1974600ba1e58fb081d96d65 SHA512 a5b6115959dc03fd6405c9e5abacaf886e71aab3f805d8ce33d4fb12793d728a3e249a125f8e28090d0a27cba289a1f18e49ca7e5737d068c57fb1f5b88878fb
+DIST ttyd-1.7.3.tar.gz 579492 BLAKE2B 14b66dbe83c0ccb601a6e3bf35a804f69f679387c9aca2f55a055dda85b2e3a396ddb4f9a3fb56575d0554837faf1d5c090cf66f4e7571201323659db3feb0b7 SHA512 e0900e2b4620095717d0f32206d08177ce74bc2f24cd9c20793cc2e370a8ee961272b73698b0dda857360703df20378c080293dfdfd287ae863801d338c8b2a4
+EBUILD ttyd-1.7.3.ebuild 647 BLAKE2B 8ed9145008c438fe7388f353f4f030c162767f3e0a8eed177355e2d6edb8e5441cd0f874bafc4f75049f284d2bb336d1656e1e7479d43f1b863d8856643b09a3 SHA512 e9953509fad3a7f3e18f19f7518dcc7c7ed6bedbe8359e09fa437874b6a2211cee9baaae4b316f0c6d8fe55beb920e3af66c2030e87d62d7fff40fef41dc3db3
+MISC metadata.xml 393 BLAKE2B 0749d48253a950098408ba52f8ea1fcd1696c055aad56663c7062efebced74438c8679d83b8d64e956e4fce8e964008029117dadfa16e480b8e8e2115dbd6b80 SHA512 9a75c9fd17ec89171a18ed02b08f952e71f7114e21f02470e72c6d2264a0f6a457a1f366b73a683c4c179aac915eba42f04139d9e8d20b96c9a92860093a9a3f
diff --git a/www-apps/ttyd/files/ttyd.confd b/www-apps/ttyd/files/ttyd.confd
new file mode 100644
index 0000000..8a79b7d
--- /dev/null
+++ b/www-apps/ttyd/files/ttyd.confd
@@ -0,0 +1,4 @@
+# conf.d file for ttyd
+
+# Please check man 1 ttyd for more information about the options
+TTYD_OPTS="-i lo -O login"
diff --git a/www-apps/ttyd/files/ttyd.initd b/www-apps/ttyd/files/ttyd.initd
new file mode 100644
index 0000000..7e8821b
--- /dev/null
+++ b/www-apps/ttyd/files/ttyd.initd
@@ -0,0 +1,14 @@
+#!/sbin/openrc-run
+# shellcheck shell=sh
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+name="ttyd daemon"
+command="/usr/bin/ttyd"
+command_args="${TTYD_OPTS}"
+command_background="true"
+pidfile="/run/ttyd.pid"
+
+depend() {
+ use logger net
+}
diff --git a/www-apps/ttyd/files/ttyd.service b/www-apps/ttyd/files/ttyd.service
new file mode 100644
index 0000000..3315ad4
--- /dev/null
+++ b/www-apps/ttyd/files/ttyd.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=ttyd daemon
+Documentation=man:ttyd(1)
+After=network.target
+
+[Service]
+EnvironmentFile=/etc/conf.d/ttyd
+ExecStart=/usr/bin/ttyd $TTYD_OPTS
+
+[Install]
+WantedBy=multi-user.target
diff --git a/www-apps/ttyd/metadata.xml b/www-apps/ttyd/metadata.xml
new file mode 100644
index 0000000..1876c3d
--- /dev/null
+++ b/www-apps/ttyd/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/tsl0922/ttyd/issues</bugs-to>
+ <remote-id type="github">tsl0922/ttyd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-apps/ttyd/ttyd-1.7.3.ebuild b/www-apps/ttyd/ttyd-1.7.3.ebuild
new file mode 100644
index 0000000..e94c231
--- /dev/null
+++ b/www-apps/ttyd/ttyd-1.7.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake systemd
+
+DESCRIPTION="Share your terminal over the web"
+HOMEPAGE="https://github.com/tsl0922/ttyd"
+SRC_URI="https://github.com/tsl0922/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/json-c:=
+ dev-libs/libuv:=
+ dev-libs/openssl:=
+ net-libs/libwebsockets:=[libuv,ssl]
+ sys-libs/zlib:=
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake_src_install
+
+ systemd_dounit "${FILESDIR}"/ttyd.service
+ newinitd "${FILESDIR}"/ttyd.initd ttyd
+ newconfd "${FILESDIR}"/ttyd.confd ttyd
+}