summaryrefslogtreecommitdiff
path: root/media-gfx/epsonscan2-non-free-plugin/epsonscan2-non-free-plugin-1.0.0.6.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2023-04-19 19:03:13 +0200
committerMarcin Deranek <marcin.deranek@booking.com>2023-04-19 19:03:13 +0200
commit92ca2d2aefce454aca658a5e0f2ea9b0ee19c202 (patch)
treea3e6b36949b8a4d5b6cb35cc044ea4f9f572c7b9 /media-gfx/epsonscan2-non-free-plugin/epsonscan2-non-free-plugin-1.0.0.6.ebuild
parent0844be4cba28d02fa53d525d37b183c1c8b98750 (diff)
downloadportage-92ca2d2aefce454aca658a5e0f2ea9b0ee19c202.tar.gz
portage-92ca2d2aefce454aca658a5e0f2ea9b0ee19c202.tar.bz2
portage-92ca2d2aefce454aca658a5e0f2ea9b0ee19c202.zip
EpsonScan update
Diffstat (limited to 'media-gfx/epsonscan2-non-free-plugin/epsonscan2-non-free-plugin-1.0.0.6.ebuild')
-rw-r--r--media-gfx/epsonscan2-non-free-plugin/epsonscan2-non-free-plugin-1.0.0.6.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-gfx/epsonscan2-non-free-plugin/epsonscan2-non-free-plugin-1.0.0.6.ebuild b/media-gfx/epsonscan2-non-free-plugin/epsonscan2-non-free-plugin-1.0.0.6.ebuild
new file mode 100644
index 0000000..0a04e4c
--- /dev/null
+++ b/media-gfx/epsonscan2-non-free-plugin/epsonscan2-non-free-plugin-1.0.0.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm
+
+DESCRIPTION="Plugins for Epson Scan 2"
+
+HOMEPAGE="https://support.epson.net/linux/en/epsonscan2.php"
+# This is distributed as part of the "bundle driver"; since we already have the
+# opensource part separately we just install the nonfree part here.
+
+EPSONSCAN2_VERSION="6.7.43.0"
+REL="1"
+
+SRC_URI="https://download2.ebz.epson.net/epsonscan2/common/rpm/x64/epsonscan2-bundle-${EPSONSCAN2_VERSION}.x86_64.rpm.tar.gz"
+LICENSE="EPSON"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="media-gfx/epsonscan2"
+RESTRICT="bindist mirror strip"
+S=${WORKDIR}
+
+src_unpack() {
+ default
+ rpm_unpack "./epsonscan2-bundle-${EPSONSCAN2_VERSION}.x86_64.rpm/plugins/${P}-${REL}.x86_64.rpm"
+}
+
+src_install() {
+ mv usr/share/doc/${P}-${REL} usr/share/doc/${P}
+ insinto /
+ doins -r usr
+ # Fix permissions
+ find "${ED}/usr/lib"* -type f -exec chmod 0755 {} +
+}