summaryrefslogtreecommitdiff
path: root/media-gfx/epsonscan2-non-free-plugin
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2023-04-19 19:03:13 +0200
committerMarcin Deranek <marcin.deranek@booking.com>2023-04-19 19:03:13 +0200
commit92ca2d2aefce454aca658a5e0f2ea9b0ee19c202 (patch)
treea3e6b36949b8a4d5b6cb35cc044ea4f9f572c7b9 /media-gfx/epsonscan2-non-free-plugin
parent0844be4cba28d02fa53d525d37b183c1c8b98750 (diff)
downloadportage-92ca2d2aefce454aca658a5e0f2ea9b0ee19c202.tar.gz
portage-92ca2d2aefce454aca658a5e0f2ea9b0ee19c202.tar.bz2
portage-92ca2d2aefce454aca658a5e0f2ea9b0ee19c202.zip
EpsonScan update
Diffstat (limited to 'media-gfx/epsonscan2-non-free-plugin')
-rw-r--r--media-gfx/epsonscan2-non-free-plugin/Manifest2
-rw-r--r--media-gfx/epsonscan2-non-free-plugin/epsonscan2-non-free-plugin-1.0.0.6.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/media-gfx/epsonscan2-non-free-plugin/Manifest b/media-gfx/epsonscan2-non-free-plugin/Manifest
index 48775c4..41bf947 100644
--- a/media-gfx/epsonscan2-non-free-plugin/Manifest
+++ b/media-gfx/epsonscan2-non-free-plugin/Manifest
@@ -1,3 +1,5 @@
DIST epsonscan2-bundle-6.7.0.0.x86_64.rpm.tar.gz 22483759 BLAKE2B a9682b6821154263c6ba85b174eb8e44361cf34e8a411662c63a855f89d09f70534d9305331319cce14642bd78d989d659076bce4cd993acc5937bce44da0ced SHA512 b51a0b9d8c3540393185723ae6b6ecd2e48504c093b9d26d447c908608d72f3d86f06c136bee6b84cda903f73f961bd448ca752f26358a0e09fd4e7388cde2c3
+DIST epsonscan2-bundle-6.7.43.0.x86_64.rpm.tar.gz 22930303 BLAKE2B 862e91a306aadca5c9e5bdf348ab72ac731b5567fc982acec8522e3efa8f0b7f720dfad9cee272c5b9a8d61875347ac9b303127ab8a1a3fecf79b014dc9bc6de SHA512 7971e6b5138b694e6bb5f9fa621fb38a1b159355eb509c135caf150e87fb17cd96336680956c4c69d80e417dd41bf79fddb6a435790495f6e04c55e834f2563f
EBUILD epsonscan2-non-free-plugin-1.0.0.5.ebuild 945 BLAKE2B 06268aac6a047c04988a329e6c3c127ad0f89e89331d2a80e3a11143e47d2eae73d53224ecc689fd4adbd956c26a17eeee4d0566510b711e07926f65bab5f3e1 SHA512 81c75af3615f0e40658248f2c5916d7429261d51e09fc34766dfcaf16fa8eeb1b50b242cf932da4ced836a7e42b354775644d1045d9ca221b9965c5a4b3b0974
+EBUILD epsonscan2-non-free-plugin-1.0.0.6.ebuild 946 BLAKE2B de855dbd244607fd913e4ae9b3e5d2fb0783182685ba28c58ded60650a0e35798cd911b9ce62e88f827aa3827eadaa0bda213b6b61326e3d45066151b307cbcf SHA512 b50baac71450896b60f6616bf9c050a9981427028e9a160329c83ed6071685723e2c64885626220f7fc915f2ff814415cde0b96917427e001132bfcac644e7c5
MISC metadata.xml 618 BLAKE2B bd895968aff2820d7857b196d6cb272e53c59da49777aa893958efbb29ad987c28bbbb75e40d98e927b60785743a5ac1e7fac5b4ad5d135fac64e04ab38f9197 SHA512 01b4a34c97d0e47d451dfaf611569d898c7b863530d6544a2882b6fab75c38dc1ca89927ab361afb62f8333374286f7e0f26a87a7833c40ad95117a138949a51
diff --git a/media-gfx/epsonscan2-non-free-plugin/epsonscan2-non-free-plugin-1.0.0.6.ebuild b/media-gfx/epsonscan2-non-free-plugin/epsonscan2-non-free-plugin-1.0.0.6.ebuild
new file mode 100644
index 0000000..0a04e4c
--- /dev/null
+++ b/media-gfx/epsonscan2-non-free-plugin/epsonscan2-non-free-plugin-1.0.0.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm
+
+DESCRIPTION="Plugins for Epson Scan 2"
+
+HOMEPAGE="https://support.epson.net/linux/en/epsonscan2.php"
+# This is distributed as part of the "bundle driver"; since we already have the
+# opensource part separately we just install the nonfree part here.
+
+EPSONSCAN2_VERSION="6.7.43.0"
+REL="1"
+
+SRC_URI="https://download2.ebz.epson.net/epsonscan2/common/rpm/x64/epsonscan2-bundle-${EPSONSCAN2_VERSION}.x86_64.rpm.tar.gz"
+LICENSE="EPSON"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="media-gfx/epsonscan2"
+RESTRICT="bindist mirror strip"
+S=${WORKDIR}
+
+src_unpack() {
+ default
+ rpm_unpack "./epsonscan2-bundle-${EPSONSCAN2_VERSION}.x86_64.rpm/plugins/${P}-${REL}.x86_64.rpm"
+}
+
+src_install() {
+ mv usr/share/doc/${P}-${REL} usr/share/doc/${P}
+ insinto /
+ doins -r usr
+ # Fix permissions
+ find "${ED}/usr/lib"* -type f -exec chmod 0755 {} +
+}