summaryrefslogtreecommitdiff
path: root/games-fps/armyops/armyops-250.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <gringo@slonko.net>2015-07-25 19:59:29 +0200
committerMarcin Deranek <gringo@slonko.net>2015-07-25 19:59:29 +0200
commit649cc1abb8de439c94f01fb9d4232fdcfcf5925c (patch)
tree67a6f6231a19065e47247b5a2470af02978cd51e /games-fps/armyops/armyops-250.ebuild
parent3fde6c0bbdfaba9a1c95e3e3a025cb60e6fd8576 (diff)
downloadportage-649cc1abb8de439c94f01fb9d4232fdcfcf5925c.tar.gz
portage-649cc1abb8de439c94f01fb9d4232fdcfcf5925c.tar.bz2
portage-649cc1abb8de439c94f01fb9d4232fdcfcf5925c.zip
Added Americas Army ebuild
Diffstat (limited to 'games-fps/armyops/armyops-250.ebuild')
-rw-r--r--games-fps/armyops/armyops-250.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/games-fps/armyops/armyops-250.ebuild b/games-fps/armyops/armyops-250.ebuild
new file mode 100644
index 0000000..7ed09ff
--- /dev/null
+++ b/games-fps/armyops/armyops-250.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/americas-army/americas-army-250.ebuild,v 1.17 2007/08/20 22:34:00 mr_bones_ Exp $
+
+inherit eutils unpacker games
+
+DESCRIPTION="military simulations by the U.S. Army to provide civilians with insights on soldiering"
+HOMEPAGE="http://www.americasarmy.com/"
+SRC_URI="mirror://3dgamers/${PN/-/}/${PN}${PV}-linux.run"
+
+LICENSE="Army-EULA"
+SLOT="0"
+KEYWORDS="amd64 x86"
+RESTRICT="mirror strip"
+IUSE="opengl"
+
+RDEPEND="sys-libs/glibc"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ games_pkg_setup
+ einfo "The installed game takes about 1.6GB of space when installed and"
+ einfo "2.4GB of space in ${PORTAGE_TMPDIR} to build!"
+ echo
+}
+
+src_unpack() {
+ unpack_makeself ${PN}${PV}-linux.run || die "unpacking game"
+ unpack ./setupstuff.tar.gz
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ local Ddir=${D}/${dir}
+
+ einfo "This will take a while... go get a pizza or something."
+
+ dodir "${dir}"
+ tar -jxf armyops${PV}.tar.bz2 -C "${Ddir}"/ || die "armyops untar failed"
+ tar -jxf binaries.tar.bz2 -C "${Ddir}"/ || die "binaries untar failed"
+
+ dodoc README.linux
+ insinto "${dir}"
+ doins ArmyOps.xpm README.linux ArmyOps${PV}_EULA.txt || die "doins failed"
+ newicon ArmyOps.xpm armyops.xpm || die "newicon failed"
+ exeinto "${dir}"
+ doexe bin/armyops || die "doexe failed"
+ fperms ug+x "${dir}"/System/pb/pbweb.x86
+
+ if use opengl ; then
+ games_make_wrapper armyops ./armyops "${dir}" "${dir}"
+ make_desktop_entry armyops "America's Army" armyops.xpm
+ fi
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ if use opengl ; then
+ elog "To play the game, run: armyops"
+ echo
+ fi
+}