summaryrefslogtreecommitdiff
path: root/games-fps
diff options
context:
space:
mode:
authorMarcin Deranek <gringo@slonko.net>2015-07-25 19:59:29 +0200
committerMarcin Deranek <gringo@slonko.net>2015-07-25 19:59:29 +0200
commit649cc1abb8de439c94f01fb9d4232fdcfcf5925c (patch)
tree67a6f6231a19065e47247b5a2470af02978cd51e /games-fps
parent3fde6c0bbdfaba9a1c95e3e3a025cb60e6fd8576 (diff)
downloadportage-649cc1abb8de439c94f01fb9d4232fdcfcf5925c.tar.gz
portage-649cc1abb8de439c94f01fb9d4232fdcfcf5925c.tar.bz2
portage-649cc1abb8de439c94f01fb9d4232fdcfcf5925c.zip
Added Americas Army ebuild
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/armyops/Manifest2
-rw-r--r--games-fps/armyops/armyops-250.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/games-fps/armyops/Manifest b/games-fps/armyops/Manifest
new file mode 100644
index 0000000..ddf241c
--- /dev/null
+++ b/games-fps/armyops/Manifest
@@ -0,0 +1,2 @@
+DIST armyops250-linux.run 813453963 SHA256 0acd87ddadee3418dfff98ad270a087aa2386e0cf86f4912ea2e30157657effe SHA512 ed4295c0d4756ae9df76b78620922752e9edeaf41b3d056d9d186b8f594288b3c637223959073d3a1ba4011f6b50db4b4b43d56e6d63880e40c94e3fdfccd215 WHIRLPOOL a75b8dd06a6996d956f6298ea37531077cf5bce92d1271a8cb5595bcb2bb98105183485ddf9ef471678c54a4adb182370b83eac52f6083e26d96d5f6142c392b
+EBUILD armyops-250.ebuild 1726 SHA256 1ce398cf1f99e904acc232de0e4882dbccaae4d77fef3ee96be8a6ed66fc7a17 SHA512 1e74958004f7be7971073030786975a9ab32cae5e6d375aa38834c1ffa1888b2cd67bb91f04a95e9d5e7a288908cd962557c3043611a7a2c9bfea44bb8788c20 WHIRLPOOL 2753a570e89ccf1e7cdcbfaadd756db7daad90d20217e70ac9780fd5fa210c0dc324ac9433e2026410e0c6649a4f8e38b425b01197f9ee2b10cb1965538de658
diff --git a/games-fps/armyops/armyops-250.ebuild b/games-fps/armyops/armyops-250.ebuild
new file mode 100644
index 0000000..7ed09ff
--- /dev/null
+++ b/games-fps/armyops/armyops-250.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/americas-army/americas-army-250.ebuild,v 1.17 2007/08/20 22:34:00 mr_bones_ Exp $
+
+inherit eutils unpacker games
+
+DESCRIPTION="military simulations by the U.S. Army to provide civilians with insights on soldiering"
+HOMEPAGE="http://www.americasarmy.com/"
+SRC_URI="mirror://3dgamers/${PN/-/}/${PN}${PV}-linux.run"
+
+LICENSE="Army-EULA"
+SLOT="0"
+KEYWORDS="amd64 x86"
+RESTRICT="mirror strip"
+IUSE="opengl"
+
+RDEPEND="sys-libs/glibc"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ games_pkg_setup
+ einfo "The installed game takes about 1.6GB of space when installed and"
+ einfo "2.4GB of space in ${PORTAGE_TMPDIR} to build!"
+ echo
+}
+
+src_unpack() {
+ unpack_makeself ${PN}${PV}-linux.run || die "unpacking game"
+ unpack ./setupstuff.tar.gz
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ local Ddir=${D}/${dir}
+
+ einfo "This will take a while... go get a pizza or something."
+
+ dodir "${dir}"
+ tar -jxf armyops${PV}.tar.bz2 -C "${Ddir}"/ || die "armyops untar failed"
+ tar -jxf binaries.tar.bz2 -C "${Ddir}"/ || die "binaries untar failed"
+
+ dodoc README.linux
+ insinto "${dir}"
+ doins ArmyOps.xpm README.linux ArmyOps${PV}_EULA.txt || die "doins failed"
+ newicon ArmyOps.xpm armyops.xpm || die "newicon failed"
+ exeinto "${dir}"
+ doexe bin/armyops || die "doexe failed"
+ fperms ug+x "${dir}"/System/pb/pbweb.x86
+
+ if use opengl ; then
+ games_make_wrapper armyops ./armyops "${dir}" "${dir}"
+ make_desktop_entry armyops "America's Army" armyops.xpm
+ fi
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ if use opengl ; then
+ elog "To play the game, run: armyops"
+ echo
+ fi
+}