summaryrefslogtreecommitdiff
path: root/games-fps/armyops/armyops-250.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2021-05-10 10:23:04 +0200
committerMarcin Deranek <marcin.deranek@booking.com>2021-05-10 10:23:04 +0200
commit44bfb0bb4804901be67c26b10104032dcf0f2468 (patch)
treedf086477fbfd60bf4d0c7408409e39c0c287a1ab /games-fps/armyops/armyops-250.ebuild
parentc8300a8082e8d546b493f0a702ec0ac176c152cb (diff)
downloadportage-44bfb0bb4804901be67c26b10104032dcf0f2468.tar.gz
portage-44bfb0bb4804901be67c26b10104032dcf0f2468.tar.bz2
portage-44bfb0bb4804901be67c26b10104032dcf0f2468.zip
Remove games.eclass from games-fps/armyops
Diffstat (limited to 'games-fps/armyops/armyops-250.ebuild')
-rw-r--r--games-fps/armyops/armyops-250.ebuild35
1 files changed, 16 insertions, 19 deletions
diff --git a/games-fps/armyops/armyops-250.ebuild b/games-fps/armyops/armyops-250.ebuild
index cc3b6ae..0319757 100644
--- a/games-fps/armyops/armyops-250.ebuild
+++ b/games-fps/armyops/armyops-250.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-inherit eutils unpacker games
+EAPI=7
+
+inherit check-reqs desktop unpacker wrapper
DESCRIPTION="Military simulations by the U.S. Army to provide insights on soldiering"
HOMEPAGE="http://www.americasarmy.com/"
@@ -17,11 +19,17 @@ RDEPEND="sys-libs/glibc"
S=${WORKDIR}
+pre_build_checks() {
+ CHECKREQS_DISK_BUILD="3G"
+ check-reqs_pkg_setup
+}
+
+pkg_pretend() {
+ pre_build_checks
+}
+
pkg_setup() {
- games_pkg_setup
- einfo "The installed game takes about 1.6GB of space when installed and"
- einfo "2.4GB of space in ${PORTAGE_TMPDIR} to build!"
- echo
+ pre_build_checks
}
src_unpack() {
@@ -30,7 +38,7 @@ src_unpack() {
}
src_install() {
- local dir=${GAMES_PREFIX_OPT}/${PN}
+ local dir=/opt/${PN}
local Ddir=${D}/${dir}
einfo "This will take a while... go get a pizza or something."
@@ -48,18 +56,7 @@ src_install() {
fperms ug+x "${dir}"/System/pb/pbweb.x86
if use opengl ; then
- games_make_wrapper armyops ./armyops "${dir}" "${dir}"
+ make_wrapper armyops ./armyops "${dir}" "${dir}"
make_desktop_entry armyops "America's Army" armyops.xpm
fi
-
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
-
- if use opengl ; then
- elog "To play the game, run: armyops"
- echo
- fi
}