summaryrefslogtreecommitdiff
path: root/games-fps
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2021-05-10 10:23:04 +0200
committerMarcin Deranek <marcin.deranek@booking.com>2021-05-10 10:23:04 +0200
commit44bfb0bb4804901be67c26b10104032dcf0f2468 (patch)
treedf086477fbfd60bf4d0c7408409e39c0c287a1ab /games-fps
parentc8300a8082e8d546b493f0a702ec0ac176c152cb (diff)
downloadportage-44bfb0bb4804901be67c26b10104032dcf0f2468.tar.gz
portage-44bfb0bb4804901be67c26b10104032dcf0f2468.tar.bz2
portage-44bfb0bb4804901be67c26b10104032dcf0f2468.zip
Remove games.eclass from games-fps/armyops
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/armyops/Manifest3
-rw-r--r--games-fps/armyops/armyops-250.ebuild35
2 files changed, 18 insertions, 20 deletions
diff --git a/games-fps/armyops/Manifest b/games-fps/armyops/Manifest
index 1fb9a02..4d8e105 100644
--- a/games-fps/armyops/Manifest
+++ b/games-fps/armyops/Manifest
@@ -1,2 +1,3 @@
DIST armyops250-linux.run 813453963 BLAKE2B 18bcb681d63981fef223b2705e504bd59b921bd5430c8689e528f4e1e5ccf623f22045ce554d75bdff21bfd449f4736cd16a967b6b1d0efc8052352dc61b7e5c SHA512 ed4295c0d4756ae9df76b78620922752e9edeaf41b3d056d9d186b8f594288b3c637223959073d3a1ba4011f6b50db4b4b43d56e6d63880e40c94e3fdfccd215
-EBUILD armyops-250.ebuild 1587 BLAKE2B 08b13a08c0d0edc61fbd89569fe845f11a9b21df176fdba63493047c8e1f63641e6fd3444c98702ea65e5f5b696174ae876987de3c5d55dfe7d3a26762ae8da0 SHA512 cb1fef6c61e21060241d45ec2a0c929963fce23e221430bfeeefe687086f44cf8bab6ba37aedb4dca9dffa68c9f75257aa3c729a777d4813b2f4a0a03cf8bd69
+EBUILD armyops-250.ebuild 1433 BLAKE2B 9c59dc4b6a8fa31fe738548c2535baa2e295857132f25d826fa58538f946a5c5f57a102f5ada73e3795f0cd31a75cdedc6f01920194650bd4c832f66d1572bd2 SHA512 7faf20c07ed1f1421ee574631babdc90a04cc1da0498c199729d4a16bb134512309246d767441d8188ca9f4175d0637118b8b51ebfbcdde7910ea6966f764306
+MISC metadata.xml 270 BLAKE2B 354405e30bba4ff898f7757cd04aaf1dee3ba1fcba299a30e29e81bf1008e1e3e0d7e1949b2eda88cf6e67f918364961cf8f7dd3d15d9a7cbb91ad6925526746 SHA512 42f10d91b3245afecee92dfb408e53a8d0d311f7764940d654947a1328e795627ec50f7ba98c6ef12d956d9fa80eba259432b7ff8663f7c6a621e6f4f51c1ba4
diff --git a/games-fps/armyops/armyops-250.ebuild b/games-fps/armyops/armyops-250.ebuild
index cc3b6ae..0319757 100644
--- a/games-fps/armyops/armyops-250.ebuild
+++ b/games-fps/armyops/armyops-250.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-inherit eutils unpacker games
+EAPI=7
+
+inherit check-reqs desktop unpacker wrapper
DESCRIPTION="Military simulations by the U.S. Army to provide insights on soldiering"
HOMEPAGE="http://www.americasarmy.com/"
@@ -17,11 +19,17 @@ RDEPEND="sys-libs/glibc"
S=${WORKDIR}
+pre_build_checks() {
+ CHECKREQS_DISK_BUILD="3G"
+ check-reqs_pkg_setup
+}
+
+pkg_pretend() {
+ pre_build_checks
+}
+
pkg_setup() {
- games_pkg_setup
- einfo "The installed game takes about 1.6GB of space when installed and"
- einfo "2.4GB of space in ${PORTAGE_TMPDIR} to build!"
- echo
+ pre_build_checks
}
src_unpack() {
@@ -30,7 +38,7 @@ src_unpack() {
}
src_install() {
- local dir=${GAMES_PREFIX_OPT}/${PN}
+ local dir=/opt/${PN}
local Ddir=${D}/${dir}
einfo "This will take a while... go get a pizza or something."
@@ -48,18 +56,7 @@ src_install() {
fperms ug+x "${dir}"/System/pb/pbweb.x86
if use opengl ; then
- games_make_wrapper armyops ./armyops "${dir}" "${dir}"
+ make_wrapper armyops ./armyops "${dir}" "${dir}"
make_desktop_entry armyops "America's Army" armyops.xpm
fi
-
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
-
- if use opengl ; then
- elog "To play the game, run: armyops"
- echo
- fi
}