summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2023-12-09 14:54:15 +0100
committerMarcin Deranek <marcin.deranek@slonko.net>2023-12-09 14:54:15 +0100
commitf984a3e8edc73a7190cdb118b134909702d45526 (patch)
tree07ab22e8fa0adc80feb88637f02f1d42717dad46 /dev-python
parentcdcfc6180b210b17c9a1f38f8603ee1f6268bc00 (diff)
downloadportage-f984a3e8edc73a7190cdb118b134909702d45526.tar.gz
portage-f984a3e8edc73a7190cdb118b134909702d45526.tar.bz2
portage-f984a3e8edc73a7190cdb118b134909702d45526.zip
dev-python/sphinx-hoverxref Initial build
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinx-hoverxref/Manifest3
-rw-r--r--dev-python/sphinx-hoverxref/metadata.xml13
-rw-r--r--dev-python/sphinx-hoverxref/sphinx-hoverxref-1.3.0.ebuild35
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/sphinx-hoverxref/Manifest b/dev-python/sphinx-hoverxref/Manifest
new file mode 100644
index 0000000..d195831
--- /dev/null
+++ b/dev-python/sphinx-hoverxref/Manifest
@@ -0,0 +1,3 @@
+DIST sphinx-hoverxref-1.3.0.gh.tar.gz 1720899 BLAKE2B dae94b9ba8fb46e76d669548d9cfb41cc858756d800c5be8bdc73fb58c44587d56dd1fdb2c402ef8cb685f03f5e09a58852dff51c4670de9116e0f35f39fdb66 SHA512 29b61e9391b973094acccfed8206dd9b49aa1954621727b7bf1e2914bf91f8840b3114937f8fde386f6d9dca680330192df66cade4f9eb9952971111de9f0cf7
+EBUILD sphinx-hoverxref-1.3.0.ebuild 841 BLAKE2B fa08d09cbf19cd9ae66c43bc67274a58d3dce7e1b84c0f9da95a516488cb2377e05ffa350449b4a84df2923d4b6db7e45f199d216d1a15e0ee59eb464179470d SHA512 142c30c234d339b458f9308ee075f7bd6f32d7a2e9beec7228f5b70bf0911f51931d5a90e3d42aa22466284bd37d75f3efd42d43475a4e190679c4fcff27c811
+MISC metadata.xml 479 BLAKE2B 382e8785e24f13aeb15e38f50800f18e846daf23550c0b95bc4629e509f35fff01fc93cfcc9c4e939c8529384b4c147fa23d43c94debfdf101748371c5c8c4a5 SHA512 bff25c65bb1170c1743aaf042f3724f48e0c54db90be8ea6cc1b107ec9994c093ad5087d82f56d47993ffd3445c42b43e713fa955b968c2cf780a62991e65386
diff --git a/dev-python/sphinx-hoverxref/metadata.xml b/dev-python/sphinx-hoverxref/metadata.xml
new file mode 100644
index 0000000..639c51f
--- /dev/null
+++ b/dev-python/sphinx-hoverxref/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/readthedocs/sphinx-hoverxref/issues</bugs-to>
+ <remote-id type="github">readthedocs/sphinx-hoverxref</remote-id>
+ <remote-id type="pypi">sphinx-hoverxref</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx-hoverxref/sphinx-hoverxref-1.3.0.ebuild b/dev-python/sphinx-hoverxref/sphinx-hoverxref-1.3.0.ebuild
new file mode 100644
index 0000000..a832739
--- /dev/null
+++ b/dev-python/sphinx-hoverxref/sphinx-hoverxref-1.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension to show tooltips with content embedded when hover a reference"
+HOMEPAGE="
+ https://pypi.org/project/sphinx-hoverxref/
+ https://github.com/readthedocs/sphinx-hoverxref
+"
+SRC_URI="https://github.com/readthedocs/sphinx-hoverxref/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+PROPERTIES="test_network"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-jquery[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/sphinxcontrib-bibtex[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+#distutils_enable_sphinx docs \
+# dev-python/sphinx-rtd-theme