summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2023-12-09 13:57:46 +0100
committerMarcin Deranek <marcin.deranek@slonko.net>2023-12-09 14:03:21 +0100
commitcdcfc6180b210b17c9a1f38f8603ee1f6268bc00 (patch)
treed5e9b5c74b7611fbeafcbdf5e286b1df9023c057 /dev-python
parent00518c6818c3cfe3b71561952f4c738ca38fc964 (diff)
downloadportage-cdcfc6180b210b17c9a1f38f8603ee1f6268bc00.tar.gz
portage-cdcfc6180b210b17c9a1f38f8603ee1f6268bc00.tar.bz2
portage-cdcfc6180b210b17c9a1f38f8603ee1f6268bc00.zip
dev-python/convertdate Initial ebuild
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/convertdate/Manifest3
-rw-r--r--dev-python/convertdate/convertdate-2.4.0.ebuild27
-rw-r--r--dev-python/convertdate/metadata.xml13
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/convertdate/Manifest b/dev-python/convertdate/Manifest
new file mode 100644
index 0000000..061644d
--- /dev/null
+++ b/dev-python/convertdate/Manifest
@@ -0,0 +1,3 @@
+DIST convertdate-2.4.0.gh.tar.gz 52728 BLAKE2B 1ee45f86c1a424f479a0a01d7f048a861cea9a25e82adade8dc26182064428b27dac98012d9a1e6afc7412f27366dd3d06ecc8d881eb6946d24a037305bb5c57 SHA512 d6b63000fd72640d69afa12b5f942684fa1c2f52880bc76e78780f144848040176a7869cd7b95a502abfd5b8fe1ebc3c844f3eb261e2ad547e6be493b11cd432
+EBUILD convertdate-2.4.0.ebuild 682 BLAKE2B 96eed60c9eb5711fda0a27b8f5752e30945ce013e670057b65052a7ec968924b9714dfa5204994abdadd7bd95bb754ec0e525e01f32ed5395d9d397e95df328b SHA512 d268cfbd732801f7f7bff90407d345bbecb3bae950e4deac5f5e14d9d1e5a9cf178aae3db218a0373647cc2a29f1491d9f9a77a3f307f7f537cc792cc6ab932c
+MISC metadata.xml 452 BLAKE2B 3850376df5cb785c6224cdff53c1e6c07d0697374a7cc1146ef5631442ba9a26907808d5d939a3b3b668b962775efac012d129a5c056712158d6154bbbd0ac77 SHA512 b332c1260b85a2574083721562437f99c1ac0a5902b4b04e8775277d9879b28273780791233352ee706a4cd1ab29e6c60bcf141aa0c53a4e99e69927653f32b9
diff --git a/dev-python/convertdate/convertdate-2.4.0.ebuild b/dev-python/convertdate/convertdate-2.4.0.ebuild
new file mode 100644
index 0000000..a120f58
--- /dev/null
+++ b/dev-python/convertdate/convertdate-2.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Converts between Gregorian dates and other calendar systems."
+HOMEPAGE="https://github.com/fitnr/convertdate https://pypi.org/project/convertdate/"
+SRC_URI="https://github.com/fitnr/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( README.md )
+
+RDEPEND="
+ >=dev-python/PyMeeus-0.3.13[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/sphinx-rtd-theme
diff --git a/dev-python/convertdate/metadata.xml b/dev-python/convertdate/metadata.xml
new file mode 100644
index 0000000..1d5044a
--- /dev/null
+++ b/dev-python/convertdate/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/fitnr/convertdate/issues</bugs-to>
+ <remote-id type="github">fitnr/convertdate</remote-id>
+ <remote-id type="pypi">convertdate</remote-id>
+ </upstream>
+</pkgmetadata>