summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2023-01-10 22:40:36 +0100
committerMarcin Deranek <marcin.deranek@booking.com>2023-01-10 22:41:04 +0100
commit9ece33c143482420b3dbe3cdae8733ae0b250682 (patch)
tree409f6965067ea6e52555aaf3ed33f63fda26c932 /dev-python
parent6432e303bab65941fc1769163d546c6993421f0a (diff)
downloadportage-9ece33c143482420b3dbe3cdae8733ae0b250682.tar.gz
portage-9ece33c143482420b3dbe3cdae8733ae0b250682.tar.bz2
portage-9ece33c143482420b3dbe3cdae8733ae0b250682.zip
dev-python/aioredis updates
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/aioredis/Manifest4
-rw-r--r--dev-python/aioredis/aioredis-1.3.1.ebuild36
-rw-r--r--dev-python/aioredis/aioredis-2.0.1.ebuild78
3 files changed, 99 insertions, 19 deletions
diff --git a/dev-python/aioredis/Manifest b/dev-python/aioredis/Manifest
index f22a71d..13b246f 100644
--- a/dev-python/aioredis/Manifest
+++ b/dev-python/aioredis/Manifest
@@ -1,3 +1,5 @@
DIST aioredis-1.3.1.tar.gz 155577 BLAKE2B eb96758c2cdd4efabe35acc4c0062c2a3d5f7b21dffdb5feacdf2967c0b6b9e7d78a801d839b8482154cc2b4de80df151be8360528e0ae3983d3ffab9f725589 SHA512 12ab821008582435ac4c4c207b7f4c75218eca072cad05d7a91961a1c8801aac18742260fa74b0aa0f1fcd05cc40e30c98ffda94f1b1b5b21a61fd6973bce1e6
-EBUILD aioredis-1.3.1.ebuild 1648 BLAKE2B 8283d3fa02db6ad5ef979ef0d91a80d021aec23df3b9e0ec8f073137781ad0958255df73c74ed290ce5bcd5b825c83e1530f74c3d5443b27cc90ade13a511d82 SHA512 41dbd9740889aab364c4aa8a0132153c63aa0a31710e30c1762c0ee8cf5dd30c9910a40919389deca458d3708d2f95aa0243423f46264bb6126cceca072652ae
+DIST aioredis-2.0.1.tar.gz 111047 BLAKE2B 56f520110bee1a5ef2c19171b6c4c5d6cd4ac440892d36edc4ebf274e7b4ac184fd9e090ad79922f609de4b1dc403a1caa38b271cb1f938357ab9f01ea3f8bfc SHA512 9c2c3fe3e4e4a91e9ca727f8ad78c7c4e6ce1109e4a3043d9ddb929606b6879b1522f3845a3b18d8586ed557a4ab0f6288f27f2b6b0e307343e113f9b9b5fd76
+EBUILD aioredis-1.3.1.ebuild 1613 BLAKE2B 0be3b4bc52e2c26b83eb6aefd52226da91bda3c97745b470f79fddef4efa8b517e892c55325515d98d7052ee2badfd1342c1fcf3eb9ed303ab3e6e861ba11c50 SHA512 c5fcff3eb1a3fd897f1d13132e23b51aa50cfabd3edf21aa6d44a8f3e434de2eb24c2a5962c3b4a42711302c37cbca9c5e88e627bdc981103a736e22798008ea
+EBUILD aioredis-2.0.1.ebuild 2182 BLAKE2B f3ec8017a42ea4271734270216f710992bc0a8ff15f6e1064f1f7180ff635ac6b7f1eb059888ecf4019e28aa996418092637116c62d8ab98bc2afdfd7f5e7290 SHA512 6508887dde5b4c13e4607be19ac51764c01835e6a465620afb509aa413f510d544396351eaefc7b2c46d8961f8799f609bff84e127f09b0897d1e6a974051013
MISC metadata.xml 454 BLAKE2B 77c9802b70fc7c671ff8b5020f85a2962f14bdeb020f2a5fc9987a52974d282ce59a3636a12c49a2fa658da601e14120841cd5f481c050f0986be19f56b51f4d SHA512 1aee633c8892c429b13bbdc671643a128acb09a560189a729b6915130a611885c1afae151638b93ac32b17252b98ab7d2fd500f9d2dcf56d55e24aa14442e760
diff --git a/dev-python/aioredis/aioredis-1.3.1.ebuild b/dev-python/aioredis/aioredis-1.3.1.ebuild
index e0869d5..94a5156 100644
--- a/dev-python/aioredis/aioredis-1.3.1.ebuild
+++ b/dev-python/aioredis/aioredis-1.3.1.ebuild
@@ -29,28 +29,28 @@ BDEPEND="
)
"
-DOCS=( README.md CHANGELOG.md )
+DOCS=( README.rst )
distutils_enable_tests pytest
EPYTEST_DESELECT=(
- # Failing tests
- tests/connection_commands_test.py::test_auth
- tests/connection_test.py::test_connect_tcp_timeout
- tests/connection_test.py::test_connect_unixsocket_timeout
- tests/pool_test.py::test_create_connection_timeout
- tests/pool_test.py::test_pool_idle_close
- tests/sentinel_commands_test.py::test_master__auth
- tests/sentinel_failover_test.py::test_auto_failover
- tests/sentinel_failover_test.py::test_failover_command
- tests/server_commands_test.py::test_client_list
- tests/server_commands_test.py::test_client_list__unixsocket
- tests/server_commands_test.py::test_command_info
- tests/server_commands_test.py::test_config_set
- tests/server_commands_test.py::test_debug_object
- tests/server_commands_test.py::test_debug_sleep
- tests/stream_commands_test.py::test_xgroup_create
- tests/stream_commands_test.py::test_xgroup_create_mkstream
+ # Failing tests
+ tests/connection_commands_test.py::test_auth
+ tests/connection_test.py::test_connect_tcp_timeout
+ tests/connection_test.py::test_connect_unixsocket_timeout
+ tests/pool_test.py::test_create_connection_timeout
+ tests/pool_test.py::test_pool_idle_close
+ tests/sentinel_commands_test.py::test_master__auth
+ tests/sentinel_failover_test.py::test_auto_failover
+ tests/sentinel_failover_test.py::test_failover_command
+ tests/server_commands_test.py::test_client_list
+ tests/server_commands_test.py::test_client_list__unixsocket
+ tests/server_commands_test.py::test_command_info
+ tests/server_commands_test.py::test_config_set
+ tests/server_commands_test.py::test_debug_object
+ tests/server_commands_test.py::test_debug_sleep
+ tests/stream_commands_test.py::test_xgroup_create
+ tests/stream_commands_test.py::test_xgroup_create_mkstream
)
python_prepare_all() {
diff --git a/dev-python/aioredis/aioredis-2.0.1.ebuild b/dev-python/aioredis/aioredis-2.0.1.ebuild
new file mode 100644
index 0000000..bda73c1
--- /dev/null
+++ b/dev-python/aioredis/aioredis-2.0.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="asyncio (PEP 3156) Redis support"
+HOMEPAGE="https://github.com/aio-libs/aioredis-py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-python/async-timeout[${PYTHON_USEDEP}]
+ dev-python/hiredis[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/pytest-asyncio
+ )
+"
+
+DOCS=( README.md CHANGELOG.md )
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Failing tests
+ tests/test_commands.py::TestRedisCommands::test_acl_getuser_setuser
+ tests/test_commands.py::TestRedisCommands::test_acl_list
+ tests/test_commands.py::TestRedisCommands::test_config_set
+ tests/test_commands.py::TestRedisCommands::test_readwrite
+ tests/test_commands.py::TestRedisCommands::test_xclaim_trimmed
+ tests/test_commands.py::TestRedisCommands::test_xgroup_create
+ tests/test_commands.py::TestRedisCommands::test_xgroup_create_mkstream
+ tests/test_commands.py::TestRedisCommands::test_xgroup_setid
+ tests/test_connection_pool.py::TestConnection::test_busy_loading_disconnects_socket
+ tests/test_connection_pool.py::TestConnection::test_busy_loading_from_pipeline
+ tests/test_connection_pool.py::TestConnection::test_busy_loading_from_pipeline_immediate_command
+ tests/test_connection_pool.py::TestConnection::test_connect_invalid_password_supplied
+ tests/test_connection_pool.py::TestConnection::test_connect_no_auth_supplied_when_required
+ tests/test_connection_pool.py::TestConnection::test_read_only_error
+)
+
+python_prepare_all() {
+ echo -e '[tool:pytest]\nasyncio_mode = auto' >> setup.cfg
+
+ distutils-r1_python_prepare_all
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<-EOF || die
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}