summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2023-01-09 00:18:19 +0100
committerMarcin Deranek <marcin.deranek@booking.com>2023-01-09 00:18:19 +0100
commit6432e303bab65941fc1769163d546c6993421f0a (patch)
tree57099952d9c20f278521fab0c87ad06ea70bc4a5 /dev-python
parent89a7c3fe0bff3457b26e99a3b897278111a190ca (diff)
downloadportage-6432e303bab65941fc1769163d546c6993421f0a.tar.gz
portage-6432e303bab65941fc1769163d546c6993421f0a.tar.bz2
portage-6432e303bab65941fc1769163d546c6993421f0a.zip
Initial dev-python/aioredis ebuild
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/aioredis/Manifest3
-rw-r--r--dev-python/aioredis/aioredis-1.3.1.ebuild62
-rw-r--r--dev-python/aioredis/metadata.xml13
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/aioredis/Manifest b/dev-python/aioredis/Manifest
new file mode 100644
index 0000000..f22a71d
--- /dev/null
+++ b/dev-python/aioredis/Manifest
@@ -0,0 +1,3 @@
+DIST aioredis-1.3.1.tar.gz 155577 BLAKE2B eb96758c2cdd4efabe35acc4c0062c2a3d5f7b21dffdb5feacdf2967c0b6b9e7d78a801d839b8482154cc2b4de80df151be8360528e0ae3983d3ffab9f725589 SHA512 12ab821008582435ac4c4c207b7f4c75218eca072cad05d7a91961a1c8801aac18742260fa74b0aa0f1fcd05cc40e30c98ffda94f1b1b5b21a61fd6973bce1e6
+EBUILD aioredis-1.3.1.ebuild 1648 BLAKE2B 8283d3fa02db6ad5ef979ef0d91a80d021aec23df3b9e0ec8f073137781ad0958255df73c74ed290ce5bcd5b825c83e1530f74c3d5443b27cc90ade13a511d82 SHA512 41dbd9740889aab364c4aa8a0132153c63aa0a31710e30c1762c0ee8cf5dd30c9910a40919389deca458d3708d2f95aa0243423f46264bb6126cceca072652ae
+MISC metadata.xml 454 BLAKE2B 77c9802b70fc7c671ff8b5020f85a2962f14bdeb020f2a5fc9987a52974d282ce59a3636a12c49a2fa658da601e14120841cd5f481c050f0986be19f56b51f4d SHA512 1aee633c8892c429b13bbdc671643a128acb09a560189a729b6915130a611885c1afae151638b93ac32b17252b98ab7d2fd500f9d2dcf56d55e24aa14442e760
diff --git a/dev-python/aioredis/aioredis-1.3.1.ebuild b/dev-python/aioredis/aioredis-1.3.1.ebuild
new file mode 100644
index 0000000..e0869d5
--- /dev/null
+++ b/dev-python/aioredis/aioredis-1.3.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="asyncio (PEP 3156) Redis support"
+HOMEPAGE="https://github.com/aio-libs/aioredis-py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-python/async-timeout[${PYTHON_USEDEP}]
+ dev-python/hiredis[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-db/redis
+ net-misc/socat
+ )
+"
+
+DOCS=( README.md CHANGELOG.md )
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Failing tests
+ tests/connection_commands_test.py::test_auth
+ tests/connection_test.py::test_connect_tcp_timeout
+ tests/connection_test.py::test_connect_unixsocket_timeout
+ tests/pool_test.py::test_create_connection_timeout
+ tests/pool_test.py::test_pool_idle_close
+ tests/sentinel_commands_test.py::test_master__auth
+ tests/sentinel_failover_test.py::test_auto_failover
+ tests/sentinel_failover_test.py::test_failover_command
+ tests/server_commands_test.py::test_client_list
+ tests/server_commands_test.py::test_client_list__unixsocket
+ tests/server_commands_test.py::test_command_info
+ tests/server_commands_test.py::test_config_set
+ tests/server_commands_test.py::test_debug_object
+ tests/server_commands_test.py::test_debug_sleep
+ tests/stream_commands_test.py::test_xgroup_create
+ tests/stream_commands_test.py::test_xgroup_create_mkstream
+)
+
+python_prepare_all() {
+ sed -e '/^addopts/d' -i setup.cfg
+ # Certificate needed
+ rm tests/ssl_test.py
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/aioredis/metadata.xml b/dev-python/aioredis/metadata.xml
new file mode 100644
index 0000000..cd674ae
--- /dev/null
+++ b/dev-python/aioredis/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/aio-libs/aioredis-py/issues</bugs-to>
+ <remote-id type="github">aio-libs/aioredis-py</remote-id>
+ <remote-id type="pypi">aioredis</remote-id>
+ </upstream>
+</pkgmetadata>