summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2022-12-26 18:18:30 +0100
committerMarcin Deranek <marcin.deranek@booking.com>2022-12-26 18:18:30 +0100
commit948456de1b862e13f58f95f083dd752cd726d8d2 (patch)
treed43264b832ae2afaaca0a2a6235d76bd0427f55b /dev-python
parent2ef0cbc6f29dc982f5a01a05dc22bcbc15d40604 (diff)
downloadportage-948456de1b862e13f58f95f083dd752cd726d8d2.tar.gz
portage-948456de1b862e13f58f95f083dd752cd726d8d2.tar.bz2
portage-948456de1b862e13f58f95f083dd752cd726d8d2.zip
Initial ebuild for dev-python/inotifyrecursive
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/inotifyrecursive/Manifest3
-rw-r--r--dev-python/inotifyrecursive/inotifyrecursive-0.3.5.ebuild22
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/inotifyrecursive/Manifest b/dev-python/inotifyrecursive/Manifest
new file mode 100644
index 0000000..c8f8425
--- /dev/null
+++ b/dev-python/inotifyrecursive/Manifest
@@ -0,0 +1,3 @@
+DIST inotifyrecursive-0.3.5.tar.gz 4576 BLAKE2B ed20d4142a5ea209b606c8025b308c8ccd965029e2b724b721d5ed466494487cecb6b8b04a6dd765738d543ca82cb99f5a56ece93283a87e94ae4c0cd51e5fd5 SHA512 23d37d1574dd8228d1905bb02ff9ae2ad56e7905482c004029c3d9f79f94da10a1255395df638dd356b69da787f4dc05d1f90eeb65d0abfedec71054c3fdc0ca
+EBUILD inotifyrecursive-0.3.5.ebuild 460 BLAKE2B 43be169ba88a5a6c70d73d63e139ddc9375745aae21464f01408878f9278689f0e324e00d5eda96555f5d0e1626f5dc3e263be4e42e3648afe2f3b9790b6a564 SHA512 695002234fbdd8155ad3c3e9d425c381f4d99c9a91322483fb48fc1a0c37a048790fb728779c41691d4c028a0d5699092295255aab6c4606773d2256c3a7f07f
+MISC metadata.xml 470 BLAKE2B 4f29f5397b48fd9e08177e45aeb6b27395fd12571c92844800fd6c01b8625c67eb9845cd611cdd63e571cd24e1826b48e8f1d03af54cf4261be23ef0eb10ef56 SHA512 619bf368306f6119027aaa8fb19af99b11f7f1528709d989331ddc540c8f205cde9d2d749a66daeeb5e8fdac19e59f05f8dbabcfa4fccbdc962710428839d655
diff --git a/dev-python/inotifyrecursive/inotifyrecursive-0.3.5.ebuild b/dev-python/inotifyrecursive/inotifyrecursive-0.3.5.ebuild
new file mode 100644
index 0000000..e3b6357
--- /dev/null
+++ b/dev-python/inotifyrecursive/inotifyrecursive-0.3.5.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Recursive inotify watches for Python"
+HOMEPAGE="https://github.com/letorbi/inotifyrecursive"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-python/inotify-simple-1.3.5
+"