summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2022-12-26 18:16:39 +0100
committerMarcin Deranek <marcin.deranek@booking.com>2022-12-26 18:16:39 +0100
commit2ef0cbc6f29dc982f5a01a05dc22bcbc15d40604 (patch)
treec2823d3814848b4e9cb6526594b0cec2c4fed66e /dev-python
parent5b6fc61d8a104e4be42fce9208a66d8308ae0724 (diff)
downloadportage-2ef0cbc6f29dc982f5a01a05dc22bcbc15d40604.tar.gz
portage-2ef0cbc6f29dc982f5a01a05dc22bcbc15d40604.tar.bz2
portage-2ef0cbc6f29dc982f5a01a05dc22bcbc15d40604.zip
Initial ebuild for dev-python/inotify-simple
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/inotify-simple/Manifest3
-rw-r--r--dev-python/inotify-simple/inotify-simple-1.3.5.ebuild19
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/inotify-simple/Manifest b/dev-python/inotify-simple/Manifest
new file mode 100644
index 0000000..51c9425
--- /dev/null
+++ b/dev-python/inotify-simple/Manifest
@@ -0,0 +1,3 @@
+DIST inotify_simple-1.3.5.tar.gz 9747 BLAKE2B 9471e0dee9821e26c0dbca1d0480333f5e310d7b2dd177d4733c66653bb365994143c7588d3efbb122b95ec6e44d87a1cca2085f6e70b970c8e0f9b66a7ead34 SHA512 fa8048786e6d4771ca63d6a2cc3e4230ec68a2d6f4bf8ca5a06056d0d261a678c3769112796a4e6a0f9c6be7331a16c4a06283d0240debb6ab407cd86b460c49
+EBUILD inotify-simple-1.3.5.ebuild 452 BLAKE2B b0172dd6d55250034984648a4972cb13655a0b214b563e0397f195ad9f93dc1449068d4b53f22721c602a98aef405a28f8b44b39167fe50b2f0d3f2bae5cec35 SHA512 3f5f2e0735f8e2468ed2fc4bad2fe628887f25bd73929a7d04807488a7bbfe8f3a78acebc3fc4606e3ecb9faf4b0b9e25907d1ed639556b28b7e2c18f01e7b75
+MISC metadata.xml 482 BLAKE2B 67742af88bf708da24fac2b43d05ac8e01ad449b374bd1eace4d0925977c35b83a3ad23798e57a62afe8aa9af2f2b4ff219245e816f12c1cd2a928e962bc29ae SHA512 9fe903a00700e3f2c31b7706cd2bbda7b1ef5ad822603ece969484557d7ea62b574bd86b4929322ab32ae32e1d07ac5aa7ff9e77c864bc640bccc150962d1bec
diff --git a/dev-python/inotify-simple/inotify-simple-1.3.5.ebuild b/dev-python/inotify-simple/inotify-simple-1.3.5.ebuild
new file mode 100644
index 0000000..a2227ac
--- /dev/null
+++ b/dev-python/inotify-simple/inotify-simple-1.3.5.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P="${PN//-/_}-${PV}"
+DESCRIPTION="Python wrapper around inotify"
+HOMEPAGE="https://github.com/chrisjbillington/inotify_simple"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"