summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2022-12-28 09:28:22 +0100
committerMarcin Deranek <marcin.deranek@booking.com>2022-12-28 09:28:22 +0100
commit3cbaea8952353b6668cb1134a5dab8c410c7c778 (patch)
tree21882f2ef218af738406171bfb10eb3809733baa /dev-python
parent0e3bf77c2509e5f1c75a1923c0881a3ccc5f6391 (diff)
downloadportage-3cbaea8952353b6668cb1134a5dab8c410c7c778.tar.gz
portage-3cbaea8952353b6668cb1134a5dab8c410c7c778.tar.bz2
portage-3cbaea8952353b6668cb1134a5dab8c410c7c778.zip
Initial ebuild for dev-python/pdf2image
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pdf2image/Manifest3
-rw-r--r--dev-python/pdf2image/metadata.xml13
-rw-r--r--dev-python/pdf2image/pdf2image-1.16.0.ebuild22
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pdf2image/Manifest b/dev-python/pdf2image/Manifest
new file mode 100644
index 0000000..037ac51
--- /dev/null
+++ b/dev-python/pdf2image/Manifest
@@ -0,0 +1,3 @@
+DIST pdf2image-1.16.0.tar.gz 11656 BLAKE2B bfc094c8486f947194965150f6e4f2cf4ad639a56dad3045bb5988003216b9ca11ef8ced9d1cff41ec5ffe4b341470d31793b4a36b30b2e2cbe170e00883c809 SHA512 fc6512d8f5ec21b5199348b9d0070dd7b3c063ada33f7024b8d9296bf3776025c85bb50a23d8d2a4b7a544bcadcc810c413ab60ad2744b96a3a0cd4d72d478e5
+EBUILD pdf2image-1.16.0.ebuild 486 BLAKE2B 1330a4cf37fcdc50a7be2a2026de5b32c77ed05aa6f89350619685b831be779e1c914108ec97c817b5fb5b4b8ea9b8ab64313950e65c66722c0f28f30423c3cd SHA512 2a13692fa7aa2055557498106f64529eb6be7c8b48d4a9c60b0b3cbec31d54991891e81b341fb80ca29e9791474edd17ec3a1db6972c4c9bb7b74b1787683bfc
+MISC metadata.xml 447 BLAKE2B 17b8836294c20fc4fcadc6732e6d5638a79721f041a6fe7c4e2cae4a1dfd4d02a8e27fd081a8d8d4d6f90a48337154799e6577dd35edb8360d6e0fdc88029a5b SHA512 36b3fc8215d04dd4c345f75ef83403221de9f626d47e9bda3c61f9d5b54d10bea9a7a6bbd7a57f1ac75d9ab11c8c729d6e64d6a9299863fed64194aadfa543de
diff --git a/dev-python/pdf2image/metadata.xml b/dev-python/pdf2image/metadata.xml
new file mode 100644
index 0000000..e1e0564
--- /dev/null
+++ b/dev-python/pdf2image/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/Belval/pdf2image/issues</bugs-to>
+ <remote-id type="github">Belval/pdf2image</remote-id>
+ <remote-id type="pypi">pdf2image</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pdf2image/pdf2image-1.16.0.ebuild b/dev-python/pdf2image/pdf2image-1.16.0.ebuild
new file mode 100644
index 0000000..7fe5bfd
--- /dev/null
+++ b/dev-python/pdf2image/pdf2image-1.16.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module that wraps pdftoppm and pdftocairo to convert PDF to a PIL Image object"
+HOMEPAGE="https://github.com/Belval/pdf2image"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-text/poppler
+ dev-python/pillow
+"