summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2023-12-09 15:04:50 +0100
committerMarcin Deranek <marcin.deranek@slonko.net>2023-12-09 15:04:50 +0100
commit2b38e635a1e44bbb08247e504faf12d66bcbfe1d (patch)
treebe3118c08eddcddda333a1602799b442efe8b44a /dev-python
parentf984a3e8edc73a7190cdb118b134909702d45526 (diff)
downloadportage-2b38e635a1e44bbb08247e504faf12d66bcbfe1d.tar.gz
portage-2b38e635a1e44bbb08247e504faf12d66bcbfe1d.tar.bz2
portage-2b38e635a1e44bbb08247e504faf12d66bcbfe1d.zip
dev-python/w3lib Initial build
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/w3lib/Manifest3
-rw-r--r--dev-python/w3lib/metadata.xml13
-rw-r--r--dev-python/w3lib/w3lib-2.1.2.ebuild24
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/w3lib/Manifest b/dev-python/w3lib/Manifest
new file mode 100644
index 0000000..a311cd9
--- /dev/null
+++ b/dev-python/w3lib/Manifest
@@ -0,0 +1,3 @@
+DIST w3lib-2.1.2.tar.gz 48715 BLAKE2B 8ec3514351634430b348d19a87e21fc95fbb230bac51b59801f692c4d2dc8426bd9740db49949efb2df80eda69026fb202ea0ae80fba45506a366c0b66bc8b29 SHA512 cfff2520cab24b84c93223125de3fb813e4d40d23a022f7fc34196c3033adb5dfc01358d62566dcc4b763d40b271e1428eba0250ba997228d07f35cd3721e37e
+EBUILD w3lib-2.1.2.ebuild 525 BLAKE2B 13af3e947c354bf773c19ec409a7cacf8fba8b880212209f63d42464b33b988d1f424fdac6dac36ba52cc22c0d9c38f15c643d7db6126456060b0302ba64feea SHA512 f159b24520c9c539fd8598c751a60c9943dae7a17572e27ddcd5cef262a1df45b2dce9a916ff3e084aa7173826f2d3e72096a418992c29c836b92a43be43b658
+MISC metadata.xml 436 BLAKE2B a4030d30a4d535c1057f32ae86382711a2241294ae6a6dde9f50c47042150a20f30aa3faa47ddc1d0d20de3d13e9d18fc2fa732ec0aab84f0267154b5daf3b47 SHA512 f10a3de829456a953b62534c5f1c81afa9bc790811080f5f501e2167a26fc1383879e4a279324fbef7351ffd1deae8d46a49d821e2e54b360035336a6afe4e36
diff --git a/dev-python/w3lib/metadata.xml b/dev-python/w3lib/metadata.xml
new file mode 100644
index 0000000..0ef0dbc
--- /dev/null
+++ b/dev-python/w3lib/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/scrapy/w3lib/issues</bugs-to>
+ <remote-id type="github">scrapy/w3lib</remote-id>
+ <remote-id type="pypi">w3lib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/w3lib/w3lib-2.1.2.ebuild b/dev-python/w3lib/w3lib-2.1.2.ebuild
new file mode 100644
index 0000000..cd67348
--- /dev/null
+++ b/dev-python/w3lib/w3lib-2.1.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..12} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Library of web-related functions"
+HOMEPAGE="
+ https://scrapy.org/
+ https://pypi.org/project/w3lib/
+ https://github.com/scrapy/w3lib
+"
+
+LICENSE="BSD"
+SLOT=0
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-hoverxref \
+ dev-python/sphinx-notfound-page