summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2023-01-03 08:35:16 +0100
committerMarcin Deranek <marcin.deranek@booking.com>2023-01-03 08:35:16 +0100
commit029f358f6dbb0bc064544276351da9b528b38457 (patch)
tree7ebe0bf48f9a1bdc45671791f5cfd11091ca1c88 /dev-python
parentebc20171b4612b6e78158ec27f08ee1b419a34b7 (diff)
downloadportage-029f358f6dbb0bc064544276351da9b528b38457.tar.gz
portage-029f358f6dbb0bc064544276351da9b528b38457.tar.bz2
portage-029f358f6dbb0bc064544276351da9b528b38457.zip
Initial ebuild for dev-python/djangorestframework
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/djangorestframework/Manifest3
-rw-r--r--dev-python/djangorestframework/djangorestframework-3.14.0.ebuild36
-rw-r--r--dev-python/djangorestframework/metadata.xml13
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/djangorestframework/Manifest b/dev-python/djangorestframework/Manifest
new file mode 100644
index 0000000..e17b5b3
--- /dev/null
+++ b/dev-python/djangorestframework/Manifest
@@ -0,0 +1,3 @@
+DIST djangorestframework-3.14.0.tar.gz 1055343 BLAKE2B 90298354a606250688609973b6fc70b3f5c842f263d39eb3989747a43a8d492362a478dd44d920bafdd94caacdce6f2b642519a388153f8835dcc2f13abd21c1 SHA512 063dde9eaaf6adede1b1ce75ec9f61581639e7f0795052019bcf9b9cc02318bd2f5fd825e6893aa2f7353c601e6792f8a52c26351bbb1e930aa841faca61f385
+EBUILD djangorestframework-3.14.0.ebuild 800 BLAKE2B 152d4f32564b191b432f0802f896a37622fc559c3af73699d01d870e2bf948ea3b2aa15b4016df55217cca8c093c32defe628c27b222e54f4aaf42ce232ae2a6 SHA512 1a78ea3136ac89fe5a0bf21176243d0f3971318724e5b6d77f61bcdbe88ddf3f123db023bed266be7d9588a449064a9c47e6d8568b8592b1ee0ee14a9f53d42c
+MISC metadata.xml 481 BLAKE2B e326944437b78270e507b01301222fe9e466b0298248a565b009fcfb21d090726b0724f0078ddae34a7bcd5744d17cdadb0bb5394b3933e967b2e0e9b46b7613 SHA512 f47cf65ab7248b22815a51ac38447a3f45f2d6e26429a49d9c5c6361c0ccebd3539e223f17a8bc3d802ca7d259f359e2c0319ed7410b3bf467cdf465c07ceaf8
diff --git a/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild b/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild
new file mode 100644
index 0000000..2d02e3a
--- /dev/null
+++ b/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Web APIs with django made easy"
+HOMEPAGE="https://www.django-rest-framework.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/django-3.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/coreapi[${PYTHON_USEDEP}]
+ dev-python/coreschema[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_description.py::TestViewNamesAndDescriptions::test_markdown
+)
diff --git a/dev-python/djangorestframework/metadata.xml b/dev-python/djangorestframework/metadata.xml
new file mode 100644
index 0000000..06d2974
--- /dev/null
+++ b/dev-python/djangorestframework/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/encode/django-rest-framework/issues</bugs-to>
+ <remote-id type="github">encode/django-rest-framework</remote-id>
+ <remote-id type="pypi">djangorestframework</remote-id>
+ </upstream>
+</pkgmetadata>