summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2023-01-03 00:03:20 +0100
committerMarcin Deranek <marcin.deranek@booking.com>2023-01-03 00:03:20 +0100
commitebc20171b4612b6e78158ec27f08ee1b419a34b7 (patch)
tree16c20213a03772a700ef947c8e0676b01e66206e /dev-python
parent60a1db12fe6cea1479c257d090c1dd8bc02dd3cd (diff)
downloadportage-ebc20171b4612b6e78158ec27f08ee1b419a34b7.tar.gz
portage-ebc20171b4612b6e78158ec27f08ee1b419a34b7.tar.bz2
portage-ebc20171b4612b6e78158ec27f08ee1b419a34b7.zip
Initial ebuild for dev-python/daphne
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/daphne/Manifest3
-rw-r--r--dev-python/daphne/daphne-4.0.0.ebuild38
-rw-r--r--dev-python/daphne/metadata.xml13
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/daphne/Manifest b/dev-python/daphne/Manifest
new file mode 100644
index 0000000..f9828c0
--- /dev/null
+++ b/dev-python/daphne/Manifest
@@ -0,0 +1,3 @@
+DIST daphne-4.0.0.gh.tar.gz 42313 BLAKE2B 3ab65d0d6bb01910bb83e3cf1a32172cd884b7160ed95cf9915db6b256f6291d57ba0c7c2f9c00ecb0ff8e258eb624ab16b553c6832f1082c8352ee108080d6b SHA512 a07bb10e70ded1d85146224d33049f790cb01693bd515086d9a0fc4072c308ba9f744ff1a7031d4a84eb7a763a13921a44c38a6af752ae68f44162351e8851f2
+EBUILD daphne-4.0.0.ebuild 806 BLAKE2B 54fbd6e5ffbdd9e185bd1330df6c13f09eb1f3955d57a60d42b5c613ddf3ff4b6d497e81b82225a5944226425896493643299feaf8ae23f6efe0cab21d247978 SHA512 810f42b76e0acba5cc5edf52a50a056820c9128974f1483338f49d07f8cb16589e313fb95155c2b0288d2c08ef21311287d29cc62a4416e058b670ea97cb7294
+MISC metadata.xml 438 BLAKE2B b5248aca993d71cd66e8df0d827ce104eaed0ab1bb6085f93c5cc0aebdd055fc2d4d61ebdb0ab14e60bd0f6b4e3896e74b863e7225e2208e2f600dab256d09b6 SHA512 9e2efec72be82988a08692f669d1f9fa0a6c80efbed384276e44d314ff47327ad99082cdcb492e2e83d23f72712ac12479abcd44772134a96addc8a4b5ab56ea
diff --git a/dev-python/daphne/daphne-4.0.0.ebuild b/dev-python/daphne/daphne-4.0.0.ebuild
new file mode 100644
index 0000000..cf91783
--- /dev/null
+++ b/dev-python/daphne/daphne-4.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP, HTTP2 and WebSocket protocol server for ASGI and ASGI-HTTP"
+HOMEPAGE="https://github.com/django/daphne"
+SRC_URI="https://github.com/django/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-python/autobahn[${PYTHON_USEDEP}]
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.rst )
+
+distutils_enable_tests pytest
+
+src_test() {
+ ASGI_THREADS=4 distutils-r1_src_test
+}
diff --git a/dev-python/daphne/metadata.xml b/dev-python/daphne/metadata.xml
new file mode 100644
index 0000000..6fe8274
--- /dev/null
+++ b/dev-python/daphne/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/django/daphne/issues</bugs-to>
+ <remote-id type="github">django/daphne</remote-id>
+ <remote-id type="pypi">daphne</remote-id>
+ </upstream>
+</pkgmetadata>