summaryrefslogtreecommitdiff
path: root/dev-python/pdf2image/pdf2image-1.16.0.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2022-12-28 09:28:22 +0100
committerMarcin Deranek <marcin.deranek@booking.com>2022-12-28 09:28:22 +0100
commit3cbaea8952353b6668cb1134a5dab8c410c7c778 (patch)
tree21882f2ef218af738406171bfb10eb3809733baa /dev-python/pdf2image/pdf2image-1.16.0.ebuild
parent0e3bf77c2509e5f1c75a1923c0881a3ccc5f6391 (diff)
downloadportage-3cbaea8952353b6668cb1134a5dab8c410c7c778.tar.gz
portage-3cbaea8952353b6668cb1134a5dab8c410c7c778.tar.bz2
portage-3cbaea8952353b6668cb1134a5dab8c410c7c778.zip
Initial ebuild for dev-python/pdf2image
Diffstat (limited to 'dev-python/pdf2image/pdf2image-1.16.0.ebuild')
-rw-r--r--dev-python/pdf2image/pdf2image-1.16.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pdf2image/pdf2image-1.16.0.ebuild b/dev-python/pdf2image/pdf2image-1.16.0.ebuild
new file mode 100644
index 0000000..7fe5bfd
--- /dev/null
+++ b/dev-python/pdf2image/pdf2image-1.16.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module that wraps pdftoppm and pdftocairo to convert PDF to a PIL Image object"
+HOMEPAGE="https://github.com/Belval/pdf2image"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-text/poppler
+ dev-python/pillow
+"