summaryrefslogtreecommitdiff
path: root/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2023-01-03 08:35:16 +0100
committerMarcin Deranek <marcin.deranek@booking.com>2023-01-03 08:35:16 +0100
commit029f358f6dbb0bc064544276351da9b528b38457 (patch)
tree7ebe0bf48f9a1bdc45671791f5cfd11091ca1c88 /dev-python/djangorestframework/djangorestframework-3.14.0.ebuild
parentebc20171b4612b6e78158ec27f08ee1b419a34b7 (diff)
downloadportage-029f358f6dbb0bc064544276351da9b528b38457.tar.gz
portage-029f358f6dbb0bc064544276351da9b528b38457.tar.bz2
portage-029f358f6dbb0bc064544276351da9b528b38457.zip
Initial ebuild for dev-python/djangorestframework
Diffstat (limited to 'dev-python/djangorestframework/djangorestframework-3.14.0.ebuild')
-rw-r--r--dev-python/djangorestframework/djangorestframework-3.14.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild b/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild
new file mode 100644
index 0000000..2d02e3a
--- /dev/null
+++ b/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Web APIs with django made easy"
+HOMEPAGE="https://www.django-rest-framework.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/django-3.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/coreapi[${PYTHON_USEDEP}]
+ dev-python/coreschema[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_description.py::TestViewNamesAndDescriptions::test_markdown
+)