summaryrefslogtreecommitdiff
path: root/dev-python/concurrent-log-handler/concurrent-log-handler-0.9.20.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2022-12-27 23:40:45 +0100
committerMarcin Deranek <marcin.deranek@booking.com>2022-12-27 23:40:45 +0100
commit985921032a90e5d7b07f1872b1b5890ce2af8004 (patch)
tree97b9f5fbdbd30a3723345198e50c232a9fec1cf9 /dev-python/concurrent-log-handler/concurrent-log-handler-0.9.20.ebuild
parent8b199f689a4a6bf163adeaf1ea9d4c3db6da810b (diff)
downloadportage-985921032a90e5d7b07f1872b1b5890ce2af8004.tar.gz
portage-985921032a90e5d7b07f1872b1b5890ce2af8004.tar.bz2
portage-985921032a90e5d7b07f1872b1b5890ce2af8004.zip
Initial ebuild for dev-python/concurrent-log-handler
Diffstat (limited to 'dev-python/concurrent-log-handler/concurrent-log-handler-0.9.20.ebuild')
-rw-r--r--dev-python/concurrent-log-handler/concurrent-log-handler-0.9.20.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/concurrent-log-handler/concurrent-log-handler-0.9.20.ebuild b/dev-python/concurrent-log-handler/concurrent-log-handler-0.9.20.ebuild
new file mode 100644
index 0000000..6933e5a
--- /dev/null
+++ b/dev-python/concurrent-log-handler/concurrent-log-handler-0.9.20.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python logging handler allowing safe concurrent write to the same log file"
+HOMEPAGE="https://github.com/Preston-Landers/concurrent-log-handler"
+SRC_URI="https://github.com/Preston-Landers/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/portalocker-1.4.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+
+python_test() {
+ ${EPYTHON} stresstest.py || die "Test failed"
+}