summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2022-12-27 23:40:45 +0100
committerMarcin Deranek <marcin.deranek@booking.com>2022-12-27 23:40:45 +0100
commit985921032a90e5d7b07f1872b1b5890ce2af8004 (patch)
tree97b9f5fbdbd30a3723345198e50c232a9fec1cf9 /dev-python
parent8b199f689a4a6bf163adeaf1ea9d4c3db6da810b (diff)
downloadportage-985921032a90e5d7b07f1872b1b5890ce2af8004.tar.gz
portage-985921032a90e5d7b07f1872b1b5890ce2af8004.tar.bz2
portage-985921032a90e5d7b07f1872b1b5890ce2af8004.zip
Initial ebuild for dev-python/concurrent-log-handler
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/concurrent-log-handler/Manifest3
-rw-r--r--dev-python/concurrent-log-handler/concurrent-log-handler-0.9.20.ebuild26
-rw-r--r--dev-python/concurrent-log-handler/metadata.xml13
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/concurrent-log-handler/Manifest b/dev-python/concurrent-log-handler/Manifest
new file mode 100644
index 0000000..7a4271c
--- /dev/null
+++ b/dev-python/concurrent-log-handler/Manifest
@@ -0,0 +1,3 @@
+DIST concurrent-log-handler-0.9.20.gh.tar.gz 24916 BLAKE2B 2345a142f4509b94ad9956cd2893ef2a342c5caa2920bdd863a3f2aea183ea957369a3b90d2d240df04f726a3cc74318c5a5dd034813b2b89efeb82ea6cc7684 SHA512 c1cde4a2c02e980d92392fd3d73c315684ac3df84dfa1f135854590d54cfb0776836a8f2b9e99b02f30afc52c01391ebe1c778dccef4c19bc31c0d22c780a27f
+EBUILD concurrent-log-handler-0.9.20.ebuild 678 BLAKE2B 74601c7656e8230fbd7fc2286f3292489914c4d0e10f3be75429f14769895c80257e98fe54c9e7974b3a327a7a40470f8071024e366e4572f8622f210d050e48 SHA512 70d838e61ebaae965205e96a81eeb5856005116fec03e601a221f6aa3e5f7adb796a3d7928de271b4bcdf2b785d40e95947992395d1fb823375852ddb8aa0e54
+MISC metadata.xml 504 BLAKE2B dcf7045a2134f0df036bc3bf43ccc3c56d0fd877a5b2761c028c1e598ae933138f7627c071fb6a3ea8f22e46e0b7c881a52ea9139decb5f2597dd028ae9c14ed SHA512 eac319d8bf80fced0734a788e1e467a742b2ba899cf532a8e5b5ab4e1204bfdab6e309da46ca488a18ab73b77dd34bfce039985e088a23446cff5b01ec123a4e
diff --git a/dev-python/concurrent-log-handler/concurrent-log-handler-0.9.20.ebuild b/dev-python/concurrent-log-handler/concurrent-log-handler-0.9.20.ebuild
new file mode 100644
index 0000000..6933e5a
--- /dev/null
+++ b/dev-python/concurrent-log-handler/concurrent-log-handler-0.9.20.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python logging handler allowing safe concurrent write to the same log file"
+HOMEPAGE="https://github.com/Preston-Landers/concurrent-log-handler"
+SRC_URI="https://github.com/Preston-Landers/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/portalocker-1.4.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+
+python_test() {
+ ${EPYTHON} stresstest.py || die "Test failed"
+}
diff --git a/dev-python/concurrent-log-handler/metadata.xml b/dev-python/concurrent-log-handler/metadata.xml
new file mode 100644
index 0000000..be13f87
--- /dev/null
+++ b/dev-python/concurrent-log-handler/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/Preston-Landers/concurrent-log-handler/issues</bugs-to>
+ <remote-id type="github">Preston-Landers/concurrent-log-handler</remote-id>
+ <remote-id type="pypi">concurrent-log-handler</remote-id>
+ </upstream>
+</pkgmetadata>