summaryrefslogtreecommitdiff
path: root/x11-wm/compiz/compiz-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/compiz/compiz-9999.ebuild')
-rw-r--r--x11-wm/compiz/compiz-9999.ebuild12
1 files changed, 1 insertions, 11 deletions
diff --git a/x11-wm/compiz/compiz-9999.ebuild b/x11-wm/compiz/compiz-9999.ebuild
index 418230e..50b92e5 100644
--- a/x11-wm/compiz/compiz-9999.ebuild
+++ b/x11-wm/compiz/compiz-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8,9} )
-inherit cmake eutils gnome2-utils xdg-utils python-single-r1 toolchain-funcs
+inherit cmake eutils xdg-utils python-single-r1 toolchain-funcs
if [[ ${PV} == 9999* ]]; then
inherit git-r3
@@ -141,13 +141,7 @@ src_install() {
python_optimize
}
-pkg_preinst() {
- use gnome && gnome2_gconf_savelist
- gnome2_icon_savelist
-}
-
pkg_postinst() {
- use gnome && gnome2_gconf_install
xdg_desktop_database_update
xdg_icon_cache_update
if use dbus; then
@@ -156,10 +150,6 @@ pkg_postinst() {
fi
}
-pkg_prerm() {
- use gnome && gnome2_gconf_uninstall
-}
-
pkg_postrm() {
xdg_desktop_database_update
xdg_icon_cache_update