summaryrefslogtreecommitdiff
path: root/x11-wm/compiz/compiz-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/compiz/compiz-9999.ebuild')
-rw-r--r--x11-wm/compiz/compiz-9999.ebuild20
1 files changed, 5 insertions, 15 deletions
diff --git a/x11-wm/compiz/compiz-9999.ebuild b/x11-wm/compiz/compiz-9999.ebuild
index d01b1bd..6edd0cb 100644
--- a/x11-wm/compiz/compiz-9999.ebuild
+++ b/x11-wm/compiz/compiz-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{8..12} )
inherit cmake xdg-utils python-single-r1 toolchain-funcs
@@ -12,31 +12,21 @@ if [[ ${PV} == 9999* ]]; then
S="${WORKDIR}/${P}"
else
SRC_URI="http://launchpad.net/${PN}/${BRANCH}/${PV}/+download/${P}.tar.xz"
+ KEYWORDS="~amd64"
fi
-KEYWORDS="~amd64"
DESCRIPTION="OpenGL window and compositing manager"
-HOMEPAGE="http://www.compiz.org/"
+HOMEPAGE="https://launchpad.net/compiz"
LICENSE="GPL-2 LGPL-2.1 MIT"
SLOT="0"
IUSE="+cairo debug dbus gles gnome gtk kde +svg test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
COMMONDEPEND="
${PYTHON_DEPS}
- !x11-wm/compiz-fusion
- !x11-libs/compiz-bcop
- !x11-libs/libcompizconfig
- !x11-libs/compizconfig-backend-gconf
- !x11-libs/compizconfig-backend-kconfig4
- !x11-plugins/compiz-plugins-main
- !x11-plugins/compiz-plugins-extra
- !x11-plugins/compiz-plugins-unsupported
- !x11-apps/ccsm
- !dev-python/compizconfig-python
- !x11-apps/fusion-icon
dev-libs/boost
dev-libs/glib:2
dev-cpp/glibmm:2
@@ -69,7 +59,6 @@ COMMONDEPEND="
x11-libs/pango
gnome? (
gnome-base/gnome-desktop:=
- gnome-base/gconf
x11-wm/metacity
)
)
@@ -123,6 +112,7 @@ src_configure() {
-DUSE_GNOME=$(usex gnome)
-DUSE_METACITY=$(usex gnome)
-DUSE_GTK=$(usex gtk)
+ -DCMAKE_CXX_STANDARD=17
-DCMAKE_BUILD_TYPE=Release
-DCOMPIZ_BUILD_TESTING=$(usex test)
-DCOMPIZ_DEFAULT_PLUGINS=composite,opengl,decor,resize,place,move,ccp