summaryrefslogtreecommitdiff
path: root/x11-wm/compiz/compiz-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/compiz/compiz-9999.ebuild')
-rw-r--r--x11-wm/compiz/compiz-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/x11-wm/compiz/compiz-9999.ebuild b/x11-wm/compiz/compiz-9999.ebuild
index 8d58d3f..6edd0cb 100644
--- a/x11-wm/compiz/compiz-9999.ebuild
+++ b/x11-wm/compiz/compiz-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{8..12} )
inherit cmake xdg-utils python-single-r1 toolchain-funcs
@@ -16,7 +16,7 @@ else
fi
DESCRIPTION="OpenGL window and compositing manager"
-HOMEPAGE="http://www.compiz.org/"
+HOMEPAGE="https://launchpad.net/compiz"
LICENSE="GPL-2 LGPL-2.1 MIT"
SLOT="0"
@@ -112,6 +112,7 @@ src_configure() {
-DUSE_GNOME=$(usex gnome)
-DUSE_METACITY=$(usex gnome)
-DUSE_GTK=$(usex gtk)
+ -DCMAKE_CXX_STANDARD=17
-DCMAKE_BUILD_TYPE=Release
-DCOMPIZ_BUILD_TESTING=$(usex test)
-DCOMPIZ_DEFAULT_PLUGINS=composite,opengl,decor,resize,place,move,ccp