summaryrefslogtreecommitdiff
path: root/www-apps/pydio/pydio-6.2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/pydio/pydio-6.2.2.ebuild')
-rw-r--r--www-apps/pydio/pydio-6.2.2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/www-apps/pydio/pydio-6.2.2.ebuild b/www-apps/pydio/pydio-6.2.2.ebuild
new file mode 100644
index 0000000..b0db8cc
--- /dev/null
+++ b/www-apps/pydio/pydio-6.2.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit webapp depend.php
+
+DESCRIPTION="File sharing platform similar to dropbox"
+HOMEPAGE="https://pyd.io/"
+SRC_URI="http://sourceforge.net/projects/ajaxplorer/files/${PN}/stable-channel/${PV}/${PN}-core-${PV}.tar.gz/download -> ${P}.tar.gz"
+RESTRICTION="mirror"
+
+LICENSE="AGPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE="+webdav"
+
+DEPEND="webdav? ( dev-php/PEAR-HTTP_WebDAV_Client )"
+RDEPEND="${DEPEND}"
+
+need_php_httpd
+
+S="${WORKDIR}/${PN}-core-${PV}"
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r "${S}"/*
+
+ insinto "${MY_HTDOCSDIR}"/upgrade-scripts
+ doins "${FILESDIR}"/*.php
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+
+ webapp_configfile "${MY_HTDOCSDIR}/base.conf.php"
+ webapp_configfile "${MY_HTDOCSDIR}/conf/bootstrap_"{conf,context,repositories}".php"
+ webapp_configfile "${MY_HTDOCSDIR}/conf/mime.types"
+ webapp_configfile "${MY_HTDOCSDIR}/conf/extensions.conf.php"
+
+ # FIXME: does not fit eclass design
+ #webapp_sqlscript mysql "${MY_HTDOCSDIR}"/plugins/*/create.mysql
+ #webapp_sqlscript postgres "${MY_HTDOCSDIR}"/plugins/*/create.pgsql
+
+ webapp_sqlscript mysql "${FILESDIR}"/6.2.0.mysql 6.0
+ webapp_sqlscript postgres "${FILESDIR}"/6.2.0.pgsql 6.0
+
+ webapp_postinst_txt en "${FILESDIR}"/postinst.en.txt
+
+ webapp_src_install
+}