summaryrefslogtreecommitdiff
path: root/sys-fs/exfat-nofuse/exfat-nofuse-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/exfat-nofuse/exfat-nofuse-9999.ebuild')
-rw-r--r--sys-fs/exfat-nofuse/exfat-nofuse-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-fs/exfat-nofuse/exfat-nofuse-9999.ebuild b/sys-fs/exfat-nofuse/exfat-nofuse-9999.ebuild
new file mode 100644
index 0000000..164a198
--- /dev/null
+++ b/sys-fs/exfat-nofuse/exfat-nofuse-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-mod git-r3
+
+DESCRIPTION="Non-fuse kernel driver for exFat and VFat file systems"
+HOMEPAGE="https://github.com/dorimanx/exfat-nofuse.git"
+
+EGIT_REPO_URI="https://github.com/dorimanx/exfat-nofuse.git git://github.com/dorimanx/exfat-nofuse.git"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="!sys-fs/fuse-exfat"
+DEPEND="${RDEPENDS}"
+
+MODULE_NAMES="exfat(kernel/fs:${S})"
+BUILD_TARGETS="all"
+
+src_prepare(){
+ sed -i -e "/^KREL/,2d" Makefile || die "sed failed"
+ default
+}
+
+src_compile(){
+ BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
+ linux-mod_src_compile
+}