summaryrefslogtreecommitdiff
path: root/net-print
diff options
context:
space:
mode:
Diffstat (limited to 'net-print')
-rw-r--r--net-print/epson-inkjet-printer-escpr2/Manifest3
-rw-r--r--net-print/epson-inkjet-printer-escpr2/epson-inkjet-printer-escpr2-1.1.11.ebuild37
-rw-r--r--net-print/epson-inkjet-printer-escpr2/files/bug_x86_64.patch76
3 files changed, 0 insertions, 116 deletions
diff --git a/net-print/epson-inkjet-printer-escpr2/Manifest b/net-print/epson-inkjet-printer-escpr2/Manifest
deleted file mode 100644
index 2b9187b..0000000
--- a/net-print/epson-inkjet-printer-escpr2/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-AUX bug_x86_64.patch 2071 BLAKE2B 33a7d09914f58a61e6f5850e6da8758b7fcf1ceab224fadda91b42bacaa2a1c3ac497ceb8b6763341f47e567fe5b9a1b9040a1c947388d08c616dee1ee0eef52 SHA512 c70859788ae0617ddc16606224b66863cee26e33da23f37724f39761fdfee3e1124e83aeca79373b55bdb90a468a6fd8a2d0733115a2b8bca941dada19efc620
-DIST epson-inkjet-printer-escpr2-1.1.11-1lsb3.2.src.rpm 2977865 BLAKE2B 3fce9eb0a442d1e1295348bf924ba3e01774b9a7331336a9cb349101eb8234edaef10f79f16efb3906365c1ecdf5d16a8e17aa77851c1efdab9e26986f4cd8ad SHA512 9e83a05e72c6d2c490d030af81f099bdee00d8582b2e034e09f0b2879f4b5370c9f076cfc186ecd270e2d8ba32765efa3daef3bdeeb2b275cac7a6ef04a5e44d
-EBUILD epson-inkjet-printer-escpr2-1.1.11.ebuild 855 BLAKE2B 946f14b2c65ec2e354405fa66de321156f259721af17c94978f6f19c697d2e626441ebc9c7aead4b44edafe997dbc2cbb6060189e12e8e2ed95b5f28c7750a8b SHA512 d16c5b0376374dd4e50b419815980651a0211f4aca1f3f6a0d854dc5676d5fe86348613799870e167f4cd92b55f2ac41a8bfa08f090bdfadab4db22d8dfe377d
diff --git a/net-print/epson-inkjet-printer-escpr2/epson-inkjet-printer-escpr2-1.1.11.ebuild b/net-print/epson-inkjet-printer-escpr2/epson-inkjet-printer-escpr2-1.1.11.ebuild
deleted file mode 100644
index c151af2..0000000
--- a/net-print/epson-inkjet-printer-escpr2/epson-inkjet-printer-escpr2-1.1.11.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit rpm
-
-DESCRIPTION="Epson Inkjet Printer Driver (ESC/P-R) 2"
-HOMEPAGE="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
-SRC_URI="https://download3.ebz.epson.net/dsc/f/03/00/11/01/98/8ff121831d0a6be76e86b87c78178f3c93df6d0f/${P}-1lsb3.2.src.rpm"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-RDEPEND="net-print/cups"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}/bug_x86_64.patch"
-)
-
-src_configure() {
- econf --disable-shared
-
- # Makefile calls ls to generate a file list which is included in Makefile.am
- # Set the collation to C to avoid automake being called automatically
- unset LC_ALL
- export LC_COLLATE=C
-}
-
-src_install() {
- emake -C ppd DESTDIR="${D}" install
- emake -C src DESTDIR="${D}" install
- einstalldocs
-}
diff --git a/net-print/epson-inkjet-printer-escpr2/files/bug_x86_64.patch b/net-print/epson-inkjet-printer-escpr2/files/bug_x86_64.patch
deleted file mode 100644
index 6bd0091..0000000
--- a/net-print/epson-inkjet-printer-escpr2/files/bug_x86_64.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-diff --git a/src/filter.c b/src/filter.c
-index d13f10e..105eae9 100755
---- a/src/filter.c
-+++ b/src/filter.c
-@@ -40,6 +40,8 @@
- #include "epson-escpr-api.h"
- #include "epson-escpr-services.h"
- #include "epson-escpr-mem.h"
-+#include "epson-escpr-services.h"
-+//#include "epson-escpage.h"
-
- #include "err.h"
- #include "mem.h"
-@@ -48,6 +50,11 @@
- #include "libprtX.h"
- #include "optBase.h"
- #include "linux_cmn.h"
-+#include "xfifo.h"
-+
-+extern EPS_ERR_CODE SetupJobAttrib (const EPS_JOB_ATTRIB*);
-+extern EPS_ERR_CODE SendStartJob ();
-+extern EPS_ERR_CODE PrintBand (const EPS_UINT8*, EPS_UINT32, EPS_UINT32*);
-
- #define WIDTH_BYTES(bits) (((bits) + 31) / 32 * 4)
-
-@@ -431,7 +438,7 @@ main (int argc, char *argv[])
- }
-
- printJob.jobStatus = EPS_STATUS_ESTABLISHED;
-- int printHeight = 0;
-+ EPS_UINT32 printHeight = 0;
- ///////////////////////////////////////////////////////////////////////////////////////////////////////////
-
- print_area_x = printJob.printableAreaWidth;
-@@ -605,7 +612,7 @@ main (int argc, char *argv[])
- memcpy(rever_buf + k*3, startpage + pos + (bandBmp.widthBytes - 6) - k*3, 3);
- }
- }
-- PrintBand (rever_buf, bandBmp.widthBytes, &printHeight);
-+ PrintBand ((const EPS_UINT8 *)rever_buf, bandBmp.widthBytes, &printHeight);
- pos -= bandBmp.widthBytes;
- }
-
-@@ -898,7 +905,7 @@ set_pips_parameter (filter_option_t *filter_opt_p, EPS_OPT *printOpt)
-
- /* Get number of pages */
- char page_num;
-- read (STDIN_FILENO, &page_num, 1);
-+ (void)read (STDIN_FILENO, &page_num, 1);
- debug_msg("total pages = %d\n", page_num);
-
- /* Others */
-@@ -949,7 +956,7 @@ EPS_INT32 print_spool_fnc(void* hParam, const EPS_UINT8* pBuf, EPS_UINT32 cbBuf)
-
- // fwrite (pBuf, cbBuf, 1, outfp);
-
-- XFIFOWrite(context, pBuf, cbBuf);
-+ XFIFOWrite(context, (char *)pBuf, cbBuf);
-
- return 1;
- }
-diff --git a/src/mem.c b/src/mem.c
-index 4b4b118..420eaf5 100755
---- a/src/mem.c
-+++ b/src/mem.c
-@@ -24,6 +24,7 @@
-
- #include <stdlib.h>
- #include "mem.h"
-+#include "err.h"
-
- void *
- mem_malloc (unsigned int size, bool_t crit)
---
-2.15.1
-