summaryrefslogtreecommitdiff
path: root/media-gfx/imagescan-plugin-network-nt/imagescan-plugin-network-nt-1.1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/imagescan-plugin-network-nt/imagescan-plugin-network-nt-1.1.3.ebuild')
-rw-r--r--media-gfx/imagescan-plugin-network-nt/imagescan-plugin-network-nt-1.1.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-gfx/imagescan-plugin-network-nt/imagescan-plugin-network-nt-1.1.3.ebuild b/media-gfx/imagescan-plugin-network-nt/imagescan-plugin-network-nt-1.1.3.ebuild
new file mode 100644
index 0000000..658b1b6
--- /dev/null
+++ b/media-gfx/imagescan-plugin-network-nt/imagescan-plugin-network-nt-1.1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info rpm
+
+DESCRIPTION="Network scanning plugin for EPSON scanners (nonfree)"
+
+HOMEPAGE="https://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+# This is distributed as part of the "bundle driver"; since we already have the
+# opensource part separately we just install the nonfree part here.
+
+ISCAN_VERSION="3.62.0"
+
+SRC_URI="https://download2.ebz.epson.net/imagescanv3/centos/latest1/rpm/x64/imagescan-bundle-centos-8-${ISCAN_VERSION}.x64.rpm.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="media-gfx/imagescan"
+RESTRICT="bindist mirror strip"
+# https://bugs.gentoo.org/364129#c15
+CONFIG_CHECK="~SYN_COOKIES"
+S=${WORKDIR}
+
+QA_PREBUILT="/usr/libexec/utsushi/networkscan"
+
+src_unpack() {
+ default
+ rpm_unpack ./imagescan-bundle-centos-8-${ISCAN_VERSION}.x64.rpm/plugins/imagescan-plugin-networkscan-${PV}-1epson4centos8.x86_64.rpm
+}
+
+src_install() {
+ exeinto /usr/libexec/utsushi
+ doexe usr/libexec/utsushi/networkscan
+
+ gunzip usr/share/doc/imagescan-plugin-networkscan/*.gz
+ dodoc usr/share/doc/imagescan-plugin-networkscan/*
+}