summaryrefslogtreecommitdiff
path: root/media-gfx/epsonscan2-non-free-plugin
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/epsonscan2-non-free-plugin')
-rw-r--r--media-gfx/epsonscan2-non-free-plugin/Manifest3
-rw-r--r--media-gfx/epsonscan2-non-free-plugin/epsonscan2-non-free-plugin-1.0.0.6.ebuild38
-rw-r--r--media-gfx/epsonscan2-non-free-plugin/metadata.xml15
3 files changed, 56 insertions, 0 deletions
diff --git a/media-gfx/epsonscan2-non-free-plugin/Manifest b/media-gfx/epsonscan2-non-free-plugin/Manifest
new file mode 100644
index 0000000..8af8763
--- /dev/null
+++ b/media-gfx/epsonscan2-non-free-plugin/Manifest
@@ -0,0 +1,3 @@
+DIST epsonscan2-bundle-6.7.63.0.x86_64.rpm.tar.gz 23147473 BLAKE2B 88ee08ce239452aec75903050e0fdc354350da6e6f46d90595988c259a97629166677c0e357ebc1b4b756dca8f96e9ddb66a0bf31c91202c635d79c761be2f05 SHA512 681f094b94daf2ae1753a9aa188e466857ef167c499d39ad48dbfca0b538eb086375afb37b426b18065ab6f656a28f766a6a778022aa18daa2a91512c49b33cd
+EBUILD epsonscan2-non-free-plugin-1.0.0.6.ebuild 983 BLAKE2B daa168297686c53849a6ec72752bd9be2f616a3c17c380c52fea79442e8630db045067ebb2f4bb59aa7084a54c60711837003ec9ad6a204dc2ce4bcc8f25f0c4 SHA512 9a1caf6e83ffd7869bb3d7fba09db5281452a6b81f2cf77547b7554c51391e060577e859fef0636c5c91f4d14bc4fb9b663467d573dc177de99b6ede40d550f8
+MISC metadata.xml 618 BLAKE2B bd895968aff2820d7857b196d6cb272e53c59da49777aa893958efbb29ad987c28bbbb75e40d98e927b60785743a5ac1e7fac5b4ad5d135fac64e04ab38f9197 SHA512 01b4a34c97d0e47d451dfaf611569d898c7b863530d6544a2882b6fab75c38dc1ca89927ab361afb62f8333374286f7e0f26a87a7833c40ad95117a138949a51
diff --git a/media-gfx/epsonscan2-non-free-plugin/epsonscan2-non-free-plugin-1.0.0.6.ebuild b/media-gfx/epsonscan2-non-free-plugin/epsonscan2-non-free-plugin-1.0.0.6.ebuild
new file mode 100644
index 0000000..b9fadfa
--- /dev/null
+++ b/media-gfx/epsonscan2-non-free-plugin/epsonscan2-non-free-plugin-1.0.0.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm
+
+DESCRIPTION="Plugins for Epson Scan 2"
+
+HOMEPAGE="https://support.epson.net/linux/en/epsonscan2.php"
+# This is distributed as part of the "bundle driver"; since we already have the
+# opensource part separately we just install the nonfree part here.
+
+EPSONSCAN2_VERSION="6.7.63.0"
+REL="1"
+
+SRC_URI="https://download3.ebz.epson.net/dsc/f/03/00/15/17/66/aef42e9eaebe3f7365ef597c7dbd8578e252beff/epsonscan2-bundle-${EPSONSCAN2_VERSION}.x86_64.rpm.tar.gz"
+S=${WORKDIR}
+
+LICENSE="EPSON"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="media-gfx/epsonscan2"
+RESTRICT="bindist mirror strip"
+
+src_unpack() {
+ default
+ rpm_unpack "./epsonscan2-bundle-${EPSONSCAN2_VERSION}.x86_64.rpm/plugins/${P}-${REL}.x86_64.rpm"
+}
+
+src_install() {
+ mv usr/share/doc/${P}-${REL} usr/share/doc/${P}
+ insinto /
+ doins -r usr
+ # Fix permissions
+ find "${ED}/usr/lib"* -type f -exec chmod 0755 {} +
+}
diff --git a/media-gfx/epsonscan2-non-free-plugin/metadata.xml b/media-gfx/epsonscan2-non-free-plugin/metadata.xml
new file mode 100644
index 0000000..2bc386c
--- /dev/null
+++ b/media-gfx/epsonscan2-non-free-plugin/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <longdescription lang="en">
+ This software provides applications to easily turn hard-copy documents
+ and imagery into formats that are more amenable to computer processing.
+ Included are a native driver for a number of EPSON scanners and a
+ compatibility driver to interface with software built around the SANE
+ standard.
+ </longdescription>
+</pkgmetadata>