summaryrefslogtreecommitdiff
path: root/dev-python/whitenoise/whitenoise-6.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/whitenoise/whitenoise-6.6.0.ebuild')
-rw-r--r--dev-python/whitenoise/whitenoise-6.6.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/whitenoise/whitenoise-6.6.0.ebuild b/dev-python/whitenoise/whitenoise-6.6.0.ebuild
new file mode 100644
index 0000000..6324dd5
--- /dev/null
+++ b/dev-python/whitenoise/whitenoise-6.6.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Radically simplified static file serving for Python web apps"
+HOMEPAGE="https://github.com/evansd/whitenoise"
+SRC_URI="https://github.com/evansd/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/furo
+
+pkg_postinst() {
+ optfeature "brotli compression" "app-arch/brotli[python]"
+}