summaryrefslogtreecommitdiff
path: root/dev-python/w3lib
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/w3lib')
-rw-r--r--dev-python/w3lib/Manifest2
-rw-r--r--dev-python/w3lib/w3lib-2.2.0.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/w3lib/Manifest b/dev-python/w3lib/Manifest
index a311cd9..2b5e3c5 100644
--- a/dev-python/w3lib/Manifest
+++ b/dev-python/w3lib/Manifest
@@ -1,3 +1,5 @@
DIST w3lib-2.1.2.tar.gz 48715 BLAKE2B 8ec3514351634430b348d19a87e21fc95fbb230bac51b59801f692c4d2dc8426bd9740db49949efb2df80eda69026fb202ea0ae80fba45506a366c0b66bc8b29 SHA512 cfff2520cab24b84c93223125de3fb813e4d40d23a022f7fc34196c3033adb5dfc01358d62566dcc4b763d40b271e1428eba0250ba997228d07f35cd3721e37e
+DIST w3lib-2.2.0.tar.gz 49428 BLAKE2B 550faccfa759db024b43d2169944bb57579591f019c45d338b053322ae79843bf47fb7d6c4dcb483939b4766c961638506299dc7974824cf8b10c264d5c5219a SHA512 8ae2fad0bd7d040544d4865a5649c942ea99fd3fa92b3f40937afd0028fc988f9d01c118cbccdb1cc320a0e70880a7ba32a1780fccc29a29895aa5aca66189fb
EBUILD w3lib-2.1.2.ebuild 525 BLAKE2B 13af3e947c354bf773c19ec409a7cacf8fba8b880212209f63d42464b33b988d1f424fdac6dac36ba52cc22c0d9c38f15c643d7db6126456060b0302ba64feea SHA512 f159b24520c9c539fd8598c751a60c9943dae7a17572e27ddcd5cef262a1df45b2dce9a916ff3e084aa7173826f2d3e72096a418992c29c836b92a43be43b658
+EBUILD w3lib-2.2.0.ebuild 557 BLAKE2B 01ed86447eaea5e170efd58febd445266a86db9d544e516a37f36df727f95b2aa1849e67b5967b2183091266e2e55ddc9b098cf4b7cbeb26dbad6b33be2bae11 SHA512 544ed460ed9aedbf786d6fde16ef0bfb1ff1db3a3912a95d57e78d0144341c2359465febda98d44499054a71143c6f09c5c1d659f5a6aaff68396e34af261a09
MISC metadata.xml 436 BLAKE2B a4030d30a4d535c1057f32ae86382711a2241294ae6a6dde9f50c47042150a20f30aa3faa47ddc1d0d20de3d13e9d18fc2fa732ec0aab84f0267154b5daf3b47 SHA512 f10a3de829456a953b62534c5f1c81afa9bc790811080f5f501e2167a26fc1383879e4a279324fbef7351ffd1deae8d46a49d821e2e54b360035336a6afe4e36
diff --git a/dev-python/w3lib/w3lib-2.2.0.ebuild b/dev-python/w3lib/w3lib-2.2.0.ebuild
new file mode 100644
index 0000000..580b8d6
--- /dev/null
+++ b/dev-python/w3lib/w3lib-2.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Library of web-related functions"
+HOMEPAGE="
+ https://scrapy.org/
+ https://pypi.org/project/w3lib/
+ https://github.com/scrapy/w3lib
+"
+
+LICENSE="BSD"
+SLOT=0
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-hoverxref \
+ dev-python/sphinx-notfound-page \
+ dev-python/sphinx-rtd-theme