summaryrefslogtreecommitdiff
path: root/dev-python/w3lib/w3lib-2.1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/w3lib/w3lib-2.1.2.ebuild')
-rw-r--r--dev-python/w3lib/w3lib-2.1.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/w3lib/w3lib-2.1.2.ebuild b/dev-python/w3lib/w3lib-2.1.2.ebuild
new file mode 100644
index 0000000..cd67348
--- /dev/null
+++ b/dev-python/w3lib/w3lib-2.1.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..12} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Library of web-related functions"
+HOMEPAGE="
+ https://scrapy.org/
+ https://pypi.org/project/w3lib/
+ https://github.com/scrapy/w3lib
+"
+
+LICENSE="BSD"
+SLOT=0
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-hoverxref \
+ dev-python/sphinx-notfound-page