summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-click/sphinx-click-4.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinx-click/sphinx-click-4.4.0.ebuild')
-rw-r--r--dev-python/sphinx-click/sphinx-click-4.4.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/sphinx-click/sphinx-click-4.4.0.ebuild b/dev-python/sphinx-click/sphinx-click-4.4.0.ebuild
new file mode 100644
index 0000000..95104e9
--- /dev/null
+++ b/dev-python/sphinx-click/sphinx-click-4.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx plugin to automatically document click-based applications"
+HOMEPAGE="
+ https://github.com/click-contrib/sphinx-click/
+ https://pypi.org/project/sphinx-click/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+"
+BDEPEND=">=dev-python/pbr-2.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs --no-autodoc