summaryrefslogtreecommitdiff
path: root/dev-python/python-ipware/python-ipware-2.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-ipware/python-ipware-2.0.0.ebuild')
-rw-r--r--dev-python/python-ipware/python-ipware-2.0.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/python-ipware/python-ipware-2.0.0.ebuild b/dev-python/python-ipware/python-ipware-2.0.0.ebuild
new file mode 100644
index 0000000..a328350
--- /dev/null
+++ b/dev-python/python-ipware/python-ipware-2.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="A Python package to retrieve user's IP address"
+HOMEPAGE="
+ https://github.com/un33k/python-ipware
+ https://pypi.org/project/python-ipware/
+"
+SRC_URI="https://github.com/un33k/python-ipware/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests unittest