summaryrefslogtreecommitdiff
path: root/dev-python/pytest-docker-tools/pytest-docker-tools-3.1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-docker-tools/pytest-docker-tools-3.1.3.ebuild')
-rw-r--r--dev-python/pytest-docker-tools/pytest-docker-tools-3.1.3.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/pytest-docker-tools/pytest-docker-tools-3.1.3.ebuild b/dev-python/pytest-docker-tools/pytest-docker-tools-3.1.3.ebuild
new file mode 100644
index 0000000..be26cf4
--- /dev/null
+++ b/dev-python/pytest-docker-tools/pytest-docker-tools-3.1.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Docker integration tests for pytest"
+HOMEPAGE="
+ https://github.com/Jc2k/pytest-docker-tools
+ https://pypi.org/project/pytest-docker-tools/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/docker[${PYTHON_USEDEP}]"