summaryrefslogtreecommitdiff
path: root/dev-python/pytest-click/pytest-click-1.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-click/pytest-click-1.1.0.ebuild')
-rw-r--r--dev-python/pytest-click/pytest-click-1.1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-click/pytest-click-1.1.0.ebuild b/dev-python/pytest-click/pytest-click-1.1.0.ebuild
new file mode 100644
index 0000000..019bf17
--- /dev/null
+++ b/dev-python/pytest-click/pytest-click-1.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+inherit distutils-r1 pypi
+
+MY_PN="${PN//-/_}"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Pytest plugin for Click"
+HOMEPAGE="
+ https://github.com/Stranger6667/pytest-click
+ https://pypi.org/project/pytest-click/
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+
+DOCS=( CHANGELOG.md README.rst )
+
+distutils_enable_tests pytest