summaryrefslogtreecommitdiff
path: root/dev-python/pytest-celery/pytest-celery-0.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-celery/pytest-celery-0.1.0.ebuild')
-rw-r--r--dev-python/pytest-celery/pytest-celery-0.1.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/pytest-celery/pytest-celery-0.1.0.ebuild b/dev-python/pytest-celery/pytest-celery-0.1.0.ebuild
new file mode 100644
index 0000000..ba6582c
--- /dev/null
+++ b/dev-python/pytest-celery/pytest-celery-0.1.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="a shim pytest plugin to enable celery.contrib.pytest"
+HOMEPAGE="
+ https://github.com/celery/pytest-celery
+ https://pypi.org/project/pytest-celery
+"
+SRC_URI="https://github.com/celery/pytest-celery/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/celery-4.4.0[${PYTHON_USEDEP}]"