summaryrefslogtreecommitdiff
path: root/dev-python/pdf2image/pdf2image-1.17.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pdf2image/pdf2image-1.17.0.ebuild')
-rw-r--r--dev-python/pdf2image/pdf2image-1.17.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pdf2image/pdf2image-1.17.0.ebuild b/dev-python/pdf2image/pdf2image-1.17.0.ebuild
new file mode 100644
index 0000000..898cac8
--- /dev/null
+++ b/dev-python/pdf2image/pdf2image-1.17.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Module that wraps pdftoppm and pdftocairo to convert PDF to a PIL Image object"
+HOMEPAGE="https://github.com/Belval/pdf2image"
+SRC_URI="https://github.com/Belval/pdf2image/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-text/poppler[cairo,jpeg,jpeg2k,png,tiff,utils]
+ dev-python/pillow
+"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs \
+ dev-python/recommonmark \
+ dev-python/sphinx-rtd-theme